Bug 99198 - stackunderflow on known-good .ps files
stackunderflow on known-good .ps files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-15 15:10 EDT by Ken Barr
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 10:50:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case. works on rh7.2 but not on rh9 (372.37 KB, application/postscript)
2003-07-15 15:11 EDT, Ken Barr
no flags Details
LD_DEBUG output showing scary set of dependent libraries (14.13 KB, text/plain)
2003-07-15 15:13 EDT, Ken Barr
no flags Details

  None (edit)
Description Ken Barr 2003-07-15 15:10:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:

When trying to view the attached file with gv, I receive the error included
below.  The same error appears when doing a ps2ps.
 
I'm able to read this file on my rh-7.2 machine, so I tried downgrading the rh9
machine to rh7.2 versions of gv and gs.  No help!  Clearly some other library on
rh9 is at fault?  I've also attached the output of LD_DEBUG=files. 
Unfortunately, it looks like there are about 20 potential rpms which may be at
fault.

Version-Release number of selected component (if applicable):
ghostscript-7.05-32.1 ?

How reproducible:
Always

Steps to Reproduce:
ps2ps CSE-TR-111-91.ps output.ps
OR
gv CSE-TR-111-91.ps

Actual Results:  Error: /stackunderflow in --astore--
Operand stack:
   false   FontBBox   --nostringval--   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1051/1123(ro)(G)--   --dict:0/20(G)--   --dict:93/200(L)--  
--dict:184/250(L)--   --dict:11/13(ro)(G)--   --dict:11/12(L)--
Current allocation mode is local
Current file position is 20993
GNU Ghostscript 7.05: Unrecoverable error, exit code 1


Expected Results:  file should convert or display correctly (as it does when
viewed on a redhat-7.2 machine)

Additional info:

rh9:
gv-3.5.8-22
ghostscript-fonts-5.50-9
ghostscript-7.05-32.1

rh7.2:
ghostscript-fonts-5.50-3
ghostscript-6.51-16.2
gv-3.5.8-18.7x
Comment 1 Ken Barr 2003-07-15 15:11:18 EDT
Created attachment 92940 [details]
test case.  works on rh7.2 but not on rh9
Comment 2 Ken Barr 2003-07-15 15:13:38 EDT
Created attachment 92941 [details]
LD_DEBUG output showing scary set of dependent libraries

setenv LD_DEBUG file ;	ps2ps CSE-TR-111-91.ps output.ps
Comment 3 Ken Barr 2003-07-15 15:40:39 EDT
should mention that gv doesn't crash on all .ps files (eg, I can view something
created by mozilla's print-to-file), just files like the one attached.
Comment 4 Alex Cherepanov 2005-03-07 06:33:24 EST
I cannot reproduce this in any version of Ghostscript on my system
compiled from sources. I don't have exact versions of the Red Hat system
to test the binary RPMs.

I can get the system  and RPM's to test the report if there's
any interest to close this issue on the Red Hat side.
Comment 5 Tim Waugh 2005-04-07 10:50:05 EDT
Seems to be fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.