Bug 9922 - kbgndwm starts too early
kbgndwm starts too early
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-02 11:25 EST by Marco Foglia
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-02 11:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Foglia 2000-03-02 11:25:41 EST
kbgndwm is executed too early in /usr/bin/startkde.

When the check for the $HOME/.kde directory is reached in
this script,

> if [ ! -d $HOME/.kde ]; then
>   cp -a /etc/skel/.kde $HOME
> fi

kbgndwm has (sometimes) already written
$HOME/.kde/share/config/kbgndwmrc. So /etc/skel/.kde is
not copied. :-(

Solution:
- put kbgndwm startup just behind the .kde check
   (leave it where it was originally)
- put .kde check at beginning of file

This problem is seems to be present in 6.2b too.

Marco Foglia
Comment 1 Bernhard Rosenkraenzer 2000-07-17 11:47:21 EDT
This was fixed in 6.2

Note You need to log in before you can comment on or make changes to this bug.