Bug 99223 - Mozilla update (15Jul2003) breaks galeon, undefined symbol begin_assignment__13nsCOMPtr_base
Mozilla update (15Jul2003) breaks galeon, undefined symbol begin_assignment__...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
: 99226 99235 99239 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-16 00:31 EDT by Eric
Modified: 2007-03-27 00:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-22 13:54:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ldd -r -d /usr/bin/galeon-bin (11.12 KB, text/plain)
2003-07-16 00:55 EDT, Eric
no flags Details

  None (edit)
Description Eric 2003-07-16 00:31:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030623

Description of problem:
The latest RedHatNetwork update of mozilla breaks galeon.  Galeon complains that
MOZILLA_FIVE_HOME is not set.  Setting it to /usr/lib/mozilla-1.0.2 allows
galeon to continue to try and start, but it fails before launching any windows
with the error message:

/usr/bin/galeon-bin: relocation error: /usr/bin/galeon-bin: undefined symbol:
begin_assignment__13nsCOMPtr_base

The script /usr/bin/galeon still refers to mozilla-1.0.1 and not the newly
installed version.  

Setting LD_LIBRARY_PATH to include /usr/lib/mozilla-1.0.2 doesn't help.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Apply all mozilla updates suggested in the latest RHN notification
2. Log out, then log back in (stopping & restarting the X server as well)
3.  Try and run "galeon"
    

Actual Results:  Galeon complained about not finding MOZILLA_FIVE_HOME set. 
Once set, it complained about the relocation error.

Expected Results:  Galeon starts normally (like it did before the update.)

Additional info:
Comment 1 Eric 2003-07-16 00:55:42 EDT
Created attachment 92957 [details]
ldd -r -d /usr/bin/galeon-bin 

These are the missing symbols.	To my uninformed eyes, it looks like L10N/I18N
stuff, possibly CJKV stuff, plus maybe some other stuff.
Comment 2 Peter 2003-07-16 18:36:06 EDT
I have the same problem. I have also started seeing Evolution crashes on stuff
that used to work...might be related since Evolution seems to depend on the same
RPMs. I've submitted a bug to ximian.
Comment 3 Ville Skyttä 2003-07-18 07:39:12 EDT
*** Bug 99226 has been marked as a duplicate of this bug. ***
Comment 4 Dan Hensley 2003-07-18 18:57:03 EDT
I was able to recompile Galeon 1.2.9 into an RPM to resolve this problem, but it
would be nice if RedHat fixes this.  Other versions of Galeon (I tried 1.2.6,
1.2.10, and 1.2.11) did not compile successfully against Mozilla 1.0.2.
Comment 5 Eric 2003-07-18 20:47:25 EDT
I was able to repair things my upgrading up a few levels as well.  I was able to
install Mozilla 1.3 binary RPM's, then upgrade galeon.  Things seem to work well
so far.  I recommend, of course, saving your mozilla and galeon config files in
case you ever want to see your bookmarks again...

Anyway, I got all the mozilla RPM files in the directory 

http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.3/Red_Hat_8x_RPMS/xft/i386/

and then put them in a directory all by themselves.  Next, I downloaded galeon
version galeon-1.2.9-1_8.x.i386.rpm from 

http://sourceforge.net/project/showfiles.php?group_id=6999

and put it in the same directory.

To upgrade, cd to the download directory where you put all the stuff, and then
install mozilla, using 

    rpm -Uvh moz*

then

    rpm -Uvh galeon*

Ecco la!  Worked for me.  YMMD. Void where prohibited.  Not available in all
states.  Etc.

I am not changing the bug status, since this is a workaround, not a fix.  I
would have preferred to keep the older mozilla for testing purposes.
Comment 6 Keith Iosso 2003-07-19 07:33:28 EDT
This one and 99235 are also duplicates of 99181.  An alternate workaround is to
uninstall (After backing up!) Mozilla 1.0.2 (which may require uninstalling
Galeon and Evolution).  Then I installed Mozilla 1.0.1, Galeon and Evolution and
was back in operation.  Mozilla 1.0.1 was still available at Ximian and on the
RHN.  
Comment 7 udippel 2003-07-20 22:16:40 EDT
Another 'workaround' which is quick and very dirty, though:
Just insert the second CD of Psyche and 
rpm --force -ivh mozilla*

It comes up with a few warnings but finally rambles on. Stable so far.
Comment 8 Brian L Scipioni 2003-07-21 07:41:36 EDT
Ditto - same exact problem after loading the new rhn MOZILLA UPDATES
Comment 9 Christopher Blizzard 2003-08-22 13:54:19 EDT
This should be fixed with the recent galeon/moz updates.
Comment 10 Christopher Blizzard 2003-08-22 13:55:59 EDT
*** Bug 99235 has been marked as a duplicate of this bug. ***
Comment 11 Christopher Blizzard 2003-08-22 13:56:28 EDT
*** Bug 99239 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.