Bug 992632 - The resolution will change when open "Display preferences"
The resolution will change when open "Display preferences"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 01:47 EDT by CongDong
Modified: 2014-08-15 08:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-15 08:49:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer debug log (8.76 KB, text/plain)
2013-08-05 01:47 EDT, CongDong
no flags Details
xorg log (216.49 KB, image/x-pcx)
2013-08-05 01:48 EDT, CongDong
no flags Details

  None (edit)
Description CongDong 2013-08-05 01:47:15 EDT
Description of problem:
Use virt-viewer to connect a running rhel guest, then open "Display preferences", the resolution will change to other.

Version-Release number of selected component (if applicable):
libvirt-0.10.2-21.el6.x86_64
virt-viewer-0.5.6-6.el6.x86_64
qemu-kvm-0.12.1.2-2.382.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Create a rhel guest with spice+qxl+spicevmc.
2.# virt-viewer $NAME
3.Open "Display preferences" in guest :   System -> Preferences -> Display preferences , and just open it is ok, don't try to change the resolution manually.
4.Repeat step3 sevral times.

Actual results:
Step4, the resolution will change everytime when do step3.

Expected results:
The resolution should not change, except change it manually.

Additional info:
Comment 1 CongDong 2013-08-05 01:47:50 EDT
Created attachment 782653 [details]
virt-viewer debug log
Comment 2 CongDong 2013-08-05 01:48:20 EDT
Created attachment 782654 [details]
xorg log
Comment 4 Marc-Andre Lureau 2013-08-19 08:11:48 EDT
the client get a resolution change from the guest, most likely a guest driver issue (probably randr related)
Comment 6 Marc-Andre Lureau 2014-08-14 15:20:07 EDT
I can't reproduce. Is it still reproducible on your side? thanks
Comment 7 CongDong 2014-08-14 22:20:09 EDT
(In reply to Marc-Andre Lureau from comment #6)
> I can't reproduce. Is it still reproducible on your side? thanks

I cannot reproduce this anymore.
Comment 8 Marc-Andre Lureau 2014-08-15 08:49:58 EDT
thanks

Note You need to log in before you can comment on or make changes to this bug.