This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 99275 - Undeclared dependency on dev
Undeclared dependency on dev
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: which (Show other bugs)
9
strongarm Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-16 17:00 EDT by Andrew E. Mileski
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-17 15:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew E. Mileski 2003-07-16 17:00:45 EDT
Description of problem:
  When installing the "which" package, an error will result from a reference to
/dev/null which is owned by "dev".  The package "which" gets installed before
"dev" since there is no dependency on the "dev" package.

Version-Release number of selected component (if applicable):
  which-2.14-5 

How reproducible:
  Everytime

Steps to Reproduce:
  I have a script that builds an image from scratch, but I doubt if it's of any
use to others.  I can attach it if necessary.

Basically, "which" is installed with a group of other co-dependent packages:
  which
  coreutils
  sysklogd
  modutils
  procps
  pam
  util-linux
  SysVinit
  dev
  initscripts
Rearranging these on the command line has little effect; "which" always seems to
get installed first.

Additional Info:
  Probably applies to all platforms (looks like x86 would have same problem). 
I'm guessing other redirections aren't detected by RPM's dependency checker, so
perhaps this is really a "rpm" bug?
Comment 1 Ngo Than 2003-07-17 06:57:55 EDT
Hm, it's not a bug in which package. it's more a problem in your install.
I assign it to anaconda.
Comment 2 Jeremy Katz 2003-07-17 14:52:27 EDT
No, if you depend on having /dev/null exist in your %post scriptlet, then you
need to Prereq the dev package.
Comment 3 Ngo Than 2003-07-17 15:07:21 EDT
it's fixed in which-2_14-7 or newer, which will be available in rawhide in next days

Note You need to log in before you can comment on or make changes to this bug.