Bug 992797 - yum-cron encoding problems
yum-cron encoding problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 991743 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 02:35 EDT by Jan ONDREJ
Modified: 2013-08-07 18:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: yum-3.4.3-105.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:56:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2013-08-05 02:35:19 EDT
Description of problem:
If fedora servers are not available, yum-cron is unable to convert some message (may be host unreachable) to proper encoding and raises an error.
I use LANG=sk_SK.UTF-8 locale.

Version-Release number of selected component (if applicable):
yum-cron-3.4.3-101.fc19.noarch

How reproducible:
I think it has something with network unreachables for fedora servers.

Actual results:
/etc/cron.daily/0yum-daily.cron:

Traceback (most recent call last):
  File "/usr/sbin/yum-cron", line 1124, in <module>
    main()
  File "/usr/sbin/yum-cron", line 1121, in main
    base.updatesCheck()
  File "/usr/sbin/yum-cron", line 1027, in updatesCheck
    self.findDeps()
  File "/usr/sbin/yum-cron", line 929, in findDeps
    self.emitCheckFailed("Failed to build transaction: %s" %(str.join("\n", resm
sg),))
  File "/usr/sbin/yum-cron", line 1086, in emitCheckFailed
    map(lambda x: x.checkFailed(error), self.emitters)
  File "/usr/sbin/yum-cron", line 1086, in <lambda>
    map(lambda x: x.checkFailed(error), self.emitters)
  File "/usr/sbin/yum-cron", line 109, in checkFailed
    self.sendMessages()
  File "/usr/sbin/yum-cron", line 689, in sendMessages
    print "".join(self.output)
UnicodeEncodeError: 'ascii' codec can't encode character u'\u017e' in position
124: ordinal not in range(128)
Comment 2 Zdeněk Pavlas 2013-08-05 07:33:38 EDT
*** Bug 991743 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-08-06 11:54:34 EDT
yum-3.4.3-105.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yum-3.4.3-105.fc19
Comment 4 Fedora Update System 2013-08-06 19:38:18 EDT
Package yum-3.4.3-105.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-105.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14361/yum-3.4.3-105.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-07 18:56:29 EDT
yum-3.4.3-105.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.