Bug 992919 - RHS-C: new component python-lockfile required
RHS-C: new component python-lockfile required
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: releng (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Anthony Towns
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 04:19 EDT by Prasanth
Modified: 2014-07-11 02:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: Big Bend
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanth 2013-08-05 04:19:53 EDT
Description of problem:

python-lockfile is missing in QE puddle http://download.lab.bos.redhat.com/rel-eng/RHS/2.1/latest/Manager/x86_64/os/Packages/. As a result, "yum install rhsc" fails:

----------------
--> Processing Dependency: python-lockfile for package: python-daemon-1.5.2-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: python-daemon-1.5.2-1.el6.noarch (rhsc)
           Requires: python-lockfile
---------------- 


Include python-lockfile also in puddle.
Comment 2 Sahina Bose 2013-08-07 02:08:21 EDT
python-lockfile is a dependency for python-daemon which is required by ovirt-engine (RHSC).
We need to include python-lockfile as part of product listing for RHSC.
Comment 3 Prasanth 2013-08-12 08:18:53 EDT
Verified.

python-daemon and its dependency python-lock-file are now available in the QE puddle http://download.lab.bos.redhat.com/rel-eng/RHS/2.1/latest/Manager/x86_64/os/Packages/

[   ] python-daemon-1.5.2-1.el6.noarch.rpm            30-Apr-2012 10:44   26K  
 
[   ] python-lockfile-0.8-5.el6.noarch.rpm            01-Jul-2013 14:48   16K  

Hope these 2 packages will get added to the RHS-C 2.1 channel as well without fail.
Comment 4 Scott Haines 2013-09-23 18:25:16 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.