Bug 992922 - hdparm is crashing during tests.
hdparm is crashing during tests.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hdparm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Michal Minar
Bruno Goncalves
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 04:24 EDT by Bruno Goncalves
Modified: 2014-08-12 08:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: hdparm-9.43-4.el6
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 03:14:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt dump (19.84 KB, application/gzip)
2013-08-05 04:27 EDT, Bruno Goncalves
no flags Details

  None (edit)
Description Bruno Goncalves 2013-08-05 04:24:30 EDT
Description of problem:
Abrt reports a crash on hdparm when executing some iSCSI test.

/sbin/hdparm -g /dev/dm-0

Aug  2 15:19:41 storageqe-02 kernel: hdparm[19014] trap divide error ip:40e892 sp:7fff3835dec0 error:0 in hdparm[400000+19000]

Process /sbin/hdparm was killed by signal 8 (SIGFPE)

Version-Release number of selected component (if applicable):
2.6.32-403.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Install RHEL-6.5
2.Perform iSCSI I/O Stress test
3.hdparm crash is reported several times, but it seems to not corrupt any data.

Actual results:
sp:7fff3835dec0 error:0 in hdparm[400000+19000]

Expected results:
no crash
Comment 2 Bruno Goncalves 2013-08-05 04:27:10 EDT
Created attachment 782725 [details]
abrt dump
Comment 6 Bruno Goncalves 2013-08-12 04:31:57 EDT
verified.

Problem does not happen when using hdparm-9.43-4.el6.
Comment 7 errata-xmlrpc 2013-11-21 03:14:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1580.html

Note You need to log in before you can comment on or make changes to this bug.