Bug 99299 - System failure when floppy with new datas umount
Summary: System failure when floppy with new datas umount
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-17 09:40 UTC by hasherfrog
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 14:33:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hasherfrog 2003-07-17 09:40:43 UTC
Description of problem:
System dies, when user try unmount floppy. Floppy (FAT) mounts OK. Then we reads 
data from floppy - OK too. Write something to floppy - OK, but when "umount 
/mnt/floppy" after writing - system down. No erros, no warnings, mouse point 
disappears, keyboard off, system hangs off.
Using mmount a:, mcopy, - identical results. mcopy faults after writing. cp may 
fault after autofsd try umount(?) floppy. KDE - when user umount floppy by menu.
This bug appears after installing video drivers for nVidia GForce4MX (drivers by 
NVidia "nvidia", not RH9 common video drivers "nv"). 
Some manipulations with /etc/fstab got us strange results: sometime (in very few 
cases) this bug do not appears, but why, it's undefined, because after rebooting 
error appears again.

Steps to Reproduce:
1.Install nVidia drivers: #sh NVIDIA-.x.something.x.y.z..;
  I have got drivers from official page of nVidia.
2.Try:
   $mount -t vfat /mnt/floppy /dev/fd0
   $cp /etc/fstab /mnt/floppy
   $umount /mnt/floppy
   ....System crash.
  or try
   $mcopy /etc/fstab a:
   ....System crash.

My videocard: GForce4MX400.

Comment 1 hasherfrog 2003-07-17 13:05:19 UTC
Some news about 99299: At nVidia forum I found one topic about lockups of nVidia 
driver under XFree86. It's recommended to update XF86 to version 4.3.0.1.
At XF86 site I have read info about this last patch and found some aviable 
causes of failure. Do I need update XFree?
But one important thing : I have see this problem WITHOUT XF, at run-level 3, 
too. And how X-server depends of file system?




Comment 2 Elliot Lee 2003-08-01 14:33:22 UTC
The nVidia drivers are unsupported for a reason.


Note You need to log in before you can comment on or make changes to this bug.