Bug 993015 - SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'nlmsg_relay' accesses on the netlink_audit_socket .
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'nlmsg_relay' ac...
Status: CLOSED DUPLICATE of bug 968158
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:91bc0569d8c398f345ba0cb52c0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 08:03 EDT by Samium Gromoff
Modified: 2013-08-05 10:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:55:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 08:03:56 EDT
Description of problem:
I am trying to run ejabberd with PAM authentication, but SELinux shoots down PAM-related machinery
during client authentication.

I have the following in my /etc/ejabberd/ejabberd.conf:
---- >8 ----
{auth_method, pam}.
{pam_service, "login"}.
---- 8< ----
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'nlmsg_relay' accesses on the netlink_audit_socket .

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that epam should be allowed nlmsg_relay access on the  netlink_audit_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep epam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:system_r:rabbitmq_beam_t:s0
Target Objects                 [ netlink_audit_socket ]
Source                        epam
Source Path                   /usr/lib64/ejabberd/priv/bin/epam
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ejabberd-2.1.13-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-300.fc19.x86_64 #1 SMP Tue
                              Jul 30 11:29:05 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-05 16:01:34 MSK
Last Seen                     2013-08-05 16:01:34 MSK
Local ID                      add0fbce-2f39-43bb-8d6c-708e7b7c6069

Raw Audit Messages
type=AVC msg=audit(1375704094.483:551): avc:  denied  { nlmsg_relay } for  pid=2498 comm="epam" scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:system_r:rabbitmq_beam_t:s0 tclass=netlink_audit_socket


type=SYSCALL msg=audit(1375704094.483:551): arch=x86_64 syscall=sendto success=no exit=EACCES a0=5 a1=7fff5b3817a0 a2=88 a3=0 items=0 ppid=2481 pid=2498 auid=4294967295 uid=991 gid=989 euid=0 suid=0 fsuid=0 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=epam exe=/usr/lib64/ejabberd/priv/bin/epam subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: epam,rabbitmq_beam_t,rabbitmq_beam_t,netlink_audit_socket,nlmsg_relay

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.4-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:55:40 EDT

*** This bug has been marked as a duplicate of bug 968158 ***

Note You need to log in before you can comment on or make changes to this bug.