Bug 993111 - [engine-backend] when attaching a local ISO domain from one host, engine does not send ConnectStorageServer to other cluster's hosts
[engine-backend] when attaching a local ISO domain from one host, engine does...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Aharon Canan
storage
:
Depends On:
Blocks: 974849
  Show dependency treegraph
 
Reported: 2013-08-05 11:37 EDT by Elad
Modified: 2016-02-10 15:24 EST (History)
8 users (show)

See Also:
Fixed In Version: is12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
logs (2.20 MB, application/x-gzip)
2013-08-05 11:37 EDT, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18229 None None None Never

  None (edit)
Description Elad 2013-08-05 11:37:37 EDT
Created attachment 782907 [details]
logs

Description of problem:
When adding a new local ISO domain from one of cluster's hosts, engine sends ConnectStorageServer only to the host that contains the domain.
All other hosts on cluster report that the domain does not exist:

Traceback (most recent call last):
  File "/usr/share/vdsm/storage/domainMonitor.py", line 190, in _monitorDomain
    self.domain = sdCache.produce(self.sdUUID)
  File "/usr/share/vdsm/storage/sdc.py", line 98, in produce
    domain.getRealDomain()
  File "/usr/share/vdsm/storage/sdc.py", line 52, in getRealDomain
    return self._cache._realProduce(self._sdUUID)
  File "/usr/share/vdsm/storage/sdc.py", line 122, in _realProduce
    domain = self._findDomain(sdUUID)
  File "/usr/share/vdsm/storage/sdc.py", line 141, in _findDomain
    dom = findMethod(sdUUID)
  File "/usr/share/vdsm/storage/sdc.py", line 171, in _findUnfetchedDomain
    raise se.StorageDomainDoesNotExist(sdUUID)
StorageDomainDoesNotExist: Storage domain does not exist: (u'e6f7cae9-2607-4699-9f4f-5e568df21caa',)




Version-Release number of selected component (if applicable):
vdsm-4.12.0-rc3.12.git139ec2f.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. on 2 hosts (or more) cluster with an active storage pool:
2. create a local iso domain on one of the host and attach it to the pool
3. select another host (not the one that contains the ISO domain storage connection path) as SPM



Actual results:
Engine sends ConnectStorageServer only to the host that contains the ISO domain.
When another host on cluster takes SPM, the local ISO domain that exist on the HSM cannot be accessed 


Expected results:
Not sure, devel need to find a solution

Additional info: logs
Comment 1 Elad 2013-08-05 11:39:06 EDT
Version-Release number of selected component (if applicable):
vdsm-4.12.0-rc3.12.git139ec2f.el6ev.x86_64
rhevm-3.3.0-0.13.master.el6ev.noarch
Comment 2 Itamar Heim 2013-08-06 02:47:38 EDT
local iso domain cannot be used by other hosts (as its local)?
if anything, it shouldn't be allowed in a non-local DC type?
Comment 3 Sergey Gotliv 2013-08-14 02:58:23 EDT
(In reply to Itamar Heim from comment #2)
> local iso domain cannot be used by other hosts (as its local)?
Correct.
> if anything, it shouldn't be allowed in a non-local DC type?
I discussed with PM different use cases of this feature. One of them is creating a path from which host can access VM ISOs and use it for installing VMs on that host. Since we don't have a term "path" in the product we have to use Local ISO Domain therefore it should be allowed in a non-local DCs and we have to verify that we managing this SD through the specific host.
Comment 4 Itamar Heim 2013-08-14 06:17:13 EDT
(In reply to Sergey Gotliv from comment #3)
> (In reply to Itamar Heim from comment #2)
> > local iso domain cannot be used by other hosts (as its local)?
> Correct.
> > if anything, it shouldn't be allowed in a non-local DC type?
> I discussed with PM different use cases of this feature. One of them is
> creating a path from which host can access VM ISOs and use it for installing
> VMs on that host. Since we don't have a term "path" in the product we have
> to use Local ISO Domain therefore it should be allowed in a non-local DCs
> and we have to verify that we managing this SD through the specific host.

sorry - i don't understand - how can two hosts mount the same "local" iso domain?
Comment 5 Sergey Gotliv 2013-08-14 07:00:11 EDT
(In reply to Itamar Heim from comment #4)
> (In reply to Sergey Gotliv from comment #3)
> > (In reply to Itamar Heim from comment #2)
> > > local iso domain cannot be used by other hosts (as its local)?
> > Correct.
> > > if anything, it shouldn't be allowed in a non-local DC type?
> > I discussed with PM different use cases of this feature. One of them is
> > creating a path from which host can access VM ISOs and use it for installing
> > VMs on that host. Since we don't have a term "path" in the product we have
> > to use Local ISO Domain therefore it should be allowed in a non-local DCs
> > and we have to verify that we managing this SD through the specific host.
> 
> sorry - i don't understand - how can two hosts mount the same "local" iso
> domain?
Local ISO Domain is mounted to one Host only. 
If in the multi host environment user want to mount only one particular host to Local ISO Storage Domain we want to allow him do that.
Comment 6 Itamar Heim 2013-08-14 07:47:10 EDT
(In reply to Sergey Gotliv from comment #5)
...
> Local ISO Domain is mounted to one Host only. 
> If in the multi host environment user want to mount only one particular host
> to Local ISO Storage Domain we want to allow him do that.

in 3.3? isn't this more in line with SDM timeline?
Comment 7 Sergey Gotliv 2013-08-16 17:53:55 EDT
(In reply to Itamar Heim from comment #6)
> (In reply to Sergey Gotliv from comment #5)
> ...
> > Local ISO Domain is mounted to one Host only. 
> > If in the multi host environment user want to mount only one particular host
> > to Local ISO Storage Domain we want to allow him do that.
> 
> in 3.3? isn't this more in line with SDM timeline?

We'll limit usage of Local ISO SD to Local DC in 3.3
Comment 8 Aharon Canan 2013-09-10 09:21:30 EDT
verified using is12

we can create local ISO only on Local DC which allow only one host, 
means the command will be send to one host that really own the path.
Comment 9 Itamar Heim 2014-01-21 17:28:40 EST
Closing - RHEV 3.3 Released
Comment 10 Itamar Heim 2014-01-21 17:28:41 EST
Closing - RHEV 3.3 Released
Comment 11 Itamar Heim 2014-01-21 17:31:40 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.