Bug 993120 - My config is not working with most recent kernel
My config is not working with most recent kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 11:58 EDT by Guillermo Gómez
Modified: 2013-08-06 14:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 14:35:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guillermo Gómez 2013-08-05 11:58:32 EDT
Description of problem:

Updated my F19 x86_64 regular laptop and now my vpnc conn is not working. Im using GNOME DE.

After some log reviews, changed to previous kernel and got it back to work.

kernel-3.9.9-301.fc19.x86_64 < works
kernel-3.10.4-300.fc19.x86_64 < fault
vpnc-0.5.3-17.svn457.fc19.x86_64
NetworkManager-vpnc-0.9.8.2-2.fc19.x86_64
NetworkManager-vpnc-gnome-0.9.8.2-2.fc19.x86_64
vpnc-script-0.5.3-17.svn457.fc19.noarch


How reproducible:


Steps to Reproduce:
1. Boot to newest kernel (3.10.x)
2. Try to connect
3. Fails with

Aug  5 09:30:52 movix NetworkManager[468]: <warn> /sys/devices/virtual/net/tun0: couldn't determine device driver; ignoring...

Actual results:

Fails to connect.


Expected results:

Successful connection.
Additional info:
Comment 1 Guillermo Gómez 2013-08-05 12:42:53 EDT
More info with previous kernel:

Aug  5 12:08:07 movix NetworkManager[3000]: <info> VPN connection 'Grupo Cluster linux SPP' (Connect) reply received.
Aug  5 12:08:07 movix NetworkManager[3000]: <warn> /sys/devices/virtual/net/tun0: couldn't determine device driver; ignoring...
Aug  5 12:08:09 movix NetworkManager[3000]: <info> VPN connection 'Grupo Cluster linux SPP' (IP4 Config Get) reply received from old-style plugin.

Same warning about tun0 but "old-style plugin" message could gives a hint on whats going on.
Comment 2 Dan Williams 2013-08-05 15:14:13 EDT
Are you able to get connected with the new kernel, but you cannot communicate with anything on the VPN?  If this is the case, can you provide the output of:

route -n
ip link show tun0
ip addr show tun0

Or does it simply not connect?  If this is the case, can you include more logs from /var/log/messages that show the connection attempt?
Comment 3 Guillermo Gómez 2013-08-06 14:35:33 EDT
Sorry, dunno exactly what happened but its working now with most recent kernel.

Maybe my last yum update fixed something, so with an updated box theres no bug at all.

Note You need to log in before you can comment on or make changes to this bug.