Bug 99321 - redhat-config-printer-gui does not properly create lpd queue with strict rfc1179 compliance for cups
redhat-config-printer-gui does not properly create lpd queue with strict rfc1...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-17 12:43 EDT by caussyn
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-17 12:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description caussyn 2003-07-17 12:43:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (X11; U; OSF1 V3.2 alpha; Nav)

Description of problem:
When creating  an lpd queue for cups (and subsequently creating an entry in
/etc/cups/printer.conf) redhat-config-printer-gui does NOT make an appropriate
modification
to the entry in /etc/cups/printer.conf.  That is, going to the queue type page,
and clicking
on the "Strict RFC1179 compliance" button does nothing.

A typical entry in /etc/cups/priint.conf looks like:
DeviceURI lpd://hostname_here/lp

However, with "Strict RFC1179 compliance" it should look like:
DeviceURI lpd://hostname_here/lp?reserve=yes

The  consequences of this is that the cups backend lpd does NOT communicate with
many lpd
daemons (for example,  lpr-0.50.5-1).



Version-Release number of selected component (if applicable):
redhat-config-printer-gui-0.6.47-1

How reproducible:
Always

Steps to Reproduce:
1. select printer that is lpd
2. select edit
3. select queue type
4. click on "strict RFC1179 compliance " button
5. click "OK"
6. click "apply"
    

Actual Results:  No changes in printer.conf file in /etc/cups/printer.conf

Expected Results:  An option should have been added, as noted in above
description.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.