Bug 993247 - server: fds are not closed even after the file is reopened
server: fds are not closed even after the file is reopened
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On: 991021
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 13:15 EDT by Pranith Kumar K
Modified: 2014-04-17 07:45 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 991021
Environment:
Last Closed: 2014-04-17 07:45:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-05 13:17:40 EDT
REVIEW: http://review.gluster.org/5499 (protocol/server: Relax lktable finodelk del_locker check) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-08-17 20:22:25 EDT
COMMIT: http://review.gluster.org/5499 committed in master by Anand Avati (avati@redhat.com) 
------
commit bb1fb1e1614d2c1646e2d512779d723b66b2a766
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Aug 5 22:20:19 2013 +0530

    protocol/server: Relax lktable finodelk del_locker check
    
    Problem:
    Client xlator issues finodelk using anon-fd when the fd is not
    opened on the file. This can also happen between attempts to re-open
    the file after client disconnects. It can so happen that lock is taken
    using anon-fd and the file is now re-opened and unlock would come with
    re-opened fd. This will lead to leak in lk-table entry, which also
    holds reference to fd which leads to fd-leak on the brick.
    
    Fix:
    Don't check for fds to be equal for tracking finodelks.
    Since inodelk is identified by (gfid, connection, lk-owner)
    fd equality is not needed.
    
    Change-Id: I62152d84caef0b863c973845e618076d388e6848
    BUG: 993247
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5499
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:45:15 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.