Bug 993274 - BPEL console testing blocked - Server start up encounters this exception: Failed to start service jboss.module.service."deployment.switchyard-bpel-console-server.war" - when S-RAMP is installed
BPEL console testing blocked - Server start up encounters this exception: Fai...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
: Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 14:54 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 13:49:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (33.06 KB, text/plain)
2013-08-05 14:55 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-08-05 14:54:42 EDT
Description of problem:

This exception is raised when the server starts: Failed to start service jboss.module.service."deployment.switchyard-bpel-console-server.war"

Version-Release number of selected component (if applicable):
jboss-eap-6.1.0.zip
soa-6.0.0.ER1-redhat-1.zip
s-ramp-6.0.0.ER1-redhat-1.zip

How reproducible:
100%

Steps to Reproduce:
1. Unzip jboss-eap-6.1.0.zip
2. Unzip soa-6.0.0.ER1-redhat-1.zip
3. Unzip s-ramp-6.0.0.ER1-redhat-1.zip
4. bin/standalone.sh

Actual results:

Caused by: org.jboss.modules.ModuleNotFoundException: org.switchyard.component.bpel:main

From the (attached) server.log

14:13:45,362 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.module.service."deployment.switchyard-bpel-console-server.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.switchyard-bpel-console-server.war".main: JBAS018759: Failed to load module: deployment.switchyard-bpel-console-server.war:main
	at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_09-icedtea]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_09-icedtea]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_09-icedtea]
Caused by: org.jboss.modules.ModuleNotFoundException: org.switchyard.component.bpel:main
	at org.jboss.modules.Module.addPaths(Module.java:949) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.Module.link(Module.java:1304) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.Module.relinkIfNecessary(Module.java:1332) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:226) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
	... 5 more


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-08-05 14:55:53 EDT
Created attachment 782969 [details]
Server log
Comment 3 George Varsamis 2013-08-19 11:57:36 EDT
This is an issue with the way layered products layer on top of one another and the way we (prod team) produce the assemblies. This issue will be fixed in ER2 when CLI scripts will be used to perform the transformation of the XML files for layered products.
Comment 4 Len DiMaggio 2013-09-24 13:48:36 EDT
Verified to be fixed in ER3.

Note You need to log in before you can comment on or make changes to this bug.