Bug 99336 - SRPM will not build due to unrecognized option
Summary: SRPM will not build due to unrecognized option
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vsftpd   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-17 19:51 UTC by Michael Lee Yohe
Modified: 2014-03-17 02:37 UTC (History)
1 user (show)

Fixed In Version: 1.2.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 04:42:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Lee Yohe 2003-07-17 19:51:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
Upon obtaining the latest vsftpd source RPM (see version-release), I was unable
to build a binary RPM due to the following error:

$ rpmbuild -bb --target i686 vsftpd.spec 
Building target platforms: i686
Building for target i686
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.42879
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf vsftpd-1.2.0
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/vsftpd-1.2.0.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd vsftpd-1.2.0
++ /usr/bin/id -u
+ '[' 500 = 0 ']'
++ /usr/bin/id -u
+ '[' 500 = 0 ']'
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ echo 'Patch #1 (vsftpd-1.1.3-rh.patch):'
Patch #1 (vsftpd-1.1.3-rh.patch):
+ patch -p1 -b --suffix .rh -s
+ echo 'Patch #2 (vsftpd-1.0.1-missingok.patch):'
Patch #2 (vsftpd-1.0.1-missingok.patch):
+ patch -p1 -b --suffix .mok -s
+ echo 'Patch #3 (vsftpd-1.2.0-tcp_wrappers.patch):'
Patch #3 (vsftpd-1.2.0-tcp_wrappers.patch):
+ patch -p1 -b --suffix .tcp_wrappers -s
+ cp /usr/src/redhat/SOURCES/vsftpd.xinetd .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.1452
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd vsftpd-1.2.0
+ LANG=C
+ export LANG
+ unset DISPLAY
+ make 'CFLAGS=-O2 -g -pipe -march=i686 -fpie -pipe' LINK=-pie
gcc -c main.c -O2 -g -pipe -march=i686 -fpie -pipe -idirafter dummyinc
cc1: unrecognized option `-fpie'
make: *** [main.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.1452 (%build)

I am not sure if "-fpie" is a GNU C 3.3 specific extension.  If it is, then a
BuildRequires should be added appropriately.

Version-Release number of selected component (if applicable):
vsftpd-1.2.0-2.1

How reproducible:
Always

Steps to Reproduce:
1. see description    

Actual Results:  see description

Expected Results:  see description

Additional info:

Comment 1 Bill Nottingham 2003-08-08 04:42:02 UTC
Buildprereqs added in 1.2.0-3, thanks!


Note You need to log in before you can comment on or make changes to this bug.