Bug 993373 - speech-dispatcher: FTBFS in rawhide
speech-dispatcher: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: speech-dispatcher (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 16:31 EDT by Dennis Gilmore
Modified: 2013-08-07 03:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 03:32:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix build failure by dropping the Python 2 bindings (2.28 KB, patch)
2013-08-07 00:58 EDT, Mathieu Bridon
no flags Details | Diff

  None (edit)
Description Dennis Gilmore 2013-08-05 16:31:59 EDT
Your package speech-dispatcher failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5772874

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Mathieu Bridon 2013-08-07 00:58:46 EDT
Created attachment 783664 [details]
Fix build failure by dropping the Python 2 bindings

Here's a patch fixing the issue.

It applies directly on the master branch of a fedpkg clone.
Comment 2 Peter Robinson 2013-08-07 03:25:10 EDT
(In reply to Mathieu Bridon from comment #1)
> Created attachment 783664 [details]
> Fix build failure by dropping the Python 2 bindings
> 
> Here's a patch fixing the issue.
> 
> It applies directly on the master branch of a fedpkg clone.

I already have a local version that builds. I originally planned to try and support both py2 and py3 bindings but was having trouble and not sure it's worth it. Thoughts?
Comment 3 Mathieu Bridon 2013-08-07 03:26:59 EDT
Upstream seems to not support Python 2 at all any more.

I tried to support both before I sent this patch, and failed as the configure script actually checks for Python >= 3.0
Comment 4 Peter Robinson 2013-08-07 03:32:32 EDT
Actually just done it. Also added obsoletes for the python2 bindings (and pushed some other changes I had locally)

Note You need to log in before you can comment on or make changes to this bug.