Bug 9935 - linuxconf gtk++ error
linuxconf gtk++ error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-03 13:05 EST by Laurent Chavey
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 17:13:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Laurent Chavey 2000-03-03 13:05:15 EST
I get an error when using linuxconf using fvwm as my
xwindow manager

here is the error message:

Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.


I have just replaced the gtk+ library with the one on the update site
(1.2.6.1) but to no avail.
Comment 1 Nalin Dahyabhai 2000-03-06 08:53:59 EST
Please upgrade to the version of gnome-linuxconf (0.24) included in Raw Hide or
the version from our 6.2 beta (0.25).  Older versions of gnome-linuxconf (which
provides the GUI front-end for LinuxConf) didn't play so well with GTK+, and the
warnings you're getting should go away if you switch to a newer version.
Comment 2 Laurent Chavey 2000-03-10 12:46:59 EST
where do I go to get the update, you are talking about 2 files but I can
not find them anywhere on the site. It would help if in the future
links to these files could be included in the error log so as to save
us some time.

thank you
Comment 3 Nalin Dahyabhai 2000-03-10 13:14:59 EST
Packages from the 6.2 beta (i386) are in
ftp://ftp.redhat.com/pub/redhat/redhat-6.2beta/i386/RedHat/RPMS/,
and the version from Raw Hide (which at this moment is identical) is
ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/.
Comment 4 Matthew Saltzman 2000-03-20 09:19:59 EST
I upgraded to gnome-linuxconf-0.25-2.  While the above error messages have
indeed been eliminated, I still get the following:

	[root@yankee]# linuxconf
	Error message from remadmin :
	Error message from remadmin :Gdk-WARNING **: locale not supported by C library

Everything else seems as normal as can be expected.
Comment 5 Nalin Dahyabhai 2000-03-20 09:38:59 EST
The locale warning usually stems from a bogus LANG environment variable, which
is set in /etc/sysconfig/i18n.  If it's set to "en" or a similar two-letter
code, change it to the proper five-letter code (i.e., "en_US") and see if that
clears it up.
Comment 6 Laurent Chavey 2000-03-20 16:46:59 EST
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.


I got the new linuxconf.rpm from the site described above
same errors, no progress at all.
the rpm that I have is 17r2-4, is this the correct one ?
Comment 7 Nalin Dahyabhai 2000-03-20 17:13:59 EST
Not exactly.  LinuxConf's user interaction is sort of client-server, and you
upgraded the half of the connection that didn't need to be upgraded.  You need
to update the gnome-linuxconf package instead.  It should be in the same
directory where the updated linuxconf package is:
ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/.
Comment 8 Nalin Dahyabhai 2000-08-03 11:08:39 EDT
This should be resolved in Raw Hide and the pinstripe beta.

Note You need to log in before you can comment on or make changes to this bug.