This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 993512 - The vm can't be started and show an kernel panic while finished installing a vm with no swap partition on rhel6.5
The vm can't be started and show an kernel panic while finished installing a ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 01:56 EDT by chentao
Modified: 2013-08-06 04:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 04:26:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chentao 2013-08-06 01:56:04 EDT
Description of problem:
The vm can't be started and show an kernel panic while finished installing a vm with no swap partition on rhel6.5. But use the physical machine do the uppper installation won't meet this problem.

Version-Release number of selected component (if applicable):
kernel-2.6.32-400.el6.x86_64
qemu-kvm-0.12.1.2-2.382.el6.x86_64
libvirt-0.10.2-21.el6.x86_64
How reproducible:
100%

Steps
1.Prepare to install a guest with rhel6.5 use virt-manager

2.Chose basic storage devices

3.Chose create custom layout,and create two standard partion /boot and /(the file system can be ext3 or ext4),do not create swap partion.

4.Chose Desktop as the default installation of Red Hat Enterprise Linux,then start install.

5.Afer the installation is finished,click reboot.

Actual results:
The vm can't be start with Kernel panic - not syncing : Attempted to kill init!
Pid:1,comm:init Not tainted 2.6.32-358.e16.x86_64 #1
Call Trace:
  [<ffffffff8150cfc8>] ? panic+0xa7/0x16f
  [<ffffffff81073ae2>] ? do_exit+0x862/0x870
  [<ffffffff81182885>] ? fput+0x25/0x30
  [<ffffffff81073b48>] ? do_group_exit+0x58/0xd0
  [<ffffffff81073bd7>] ? sys_exit_group+0x17/0x20
  [<ffffffff8100b072>] ? system_call_fastpath+0x16/0


Expected results:
The vm should be reboot sucessfully.
Comment 2 chentao 2013-08-06 02:27:48 EDT
The virt-manager version is virt-manager-0.9.0-18.el6.x86_64.
Comment 3 Martin Kletzander 2013-08-06 04:26:43 EDT
The VM has not enough memory and since the guest has nowhere to swap, OOM killer starts killing processes.  After it has nothing to kill, you get to this point.  The problem is not enough RAM and that is a thing you need to properly configure (change from the default) in case you change the default in the guest.

Note You need to log in before you can comment on or make changes to this bug.