Bug 993642 - [openstack-puppet-modules] Installation of openstack 'controller' using the foreman fails due 'Invalid parameter glance_user_password at controller.pp:99'.
[openstack-puppet-modules] Installation of openstack 'controller' using the f...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
3.0
x86_64 Linux
urgent Severity urgent
: z2
: 3.0
Assigned To: Jordan OMara
Omri Hochman
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 06:50 EDT by Omri Hochman
Modified: 2014-11-09 17:56 EST (History)
8 users (show)

See Also:
Fixed In Version: ruby193-openstack-foreman-installer-0.0.18-3.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, installation of an OpenStack controller node using the Foreman fails with an error of 'Invalid parameter glance_user_password at <filepath>/controller.pp:99'. This has been fixed so that the Foreman now correctly creates a controller.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 15:58:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2013-08-06 06:50:45 EDT
[openstack-puppet-modules] Installation of openstack 'controller' using the foreman fails due 'Invalid parameter glance_user_password at controller.pp:99'.


Environment:
-------------
packstack-modules-puppet-2013.1.1-0.24.dev651.el6ost.noarch
ruby193-puppet-3.1.1-11.el6ost.noarch
ruby193-rubygem-sinatra-1.3.6-20.el6ost.noarch
ruby193-rubygem-passenger-3.0.17-11.el6ost.x86_64
ruby193-mod_passenger-3.0.17-11.el6ost.x86_64
ruby-libs-1.8.7.352-12.el6_4.x86_64
ruby-augeas-0.4.1-1.el6ost.x86_64
ruby193-puppet-server-3.1.1-11.el6ost.noarch
ruby193-rubygem-spruz-0.2.5-4.el6ost.noarch
ruby-1.8.7.352-12.el6_4.x86_64
ruby193-v8-3.10.8-4.el6.x86_64


Scenario:
---------
Follow the steps from this guide: http://developerblog.redhat.com/2013/07/12/managing-openstack-with-the-foreman/
After foreman installation complete, add a client to 'controller Host-Group' and attempt and run 'scl enable ruby193 "puppet agent -t -v"' on the client machine.

Results:
---------
[root@puma02 tmp]# scl enable ruby193 "puppet agent -t -v"
Info: Retrieving plugin
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/pe_version.rb
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/puppet_vardir.rb
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/iptables_version.rb
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/facter_dot_d.rb
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/ip6tables_version.rb
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /opt/rh/ruby193/root/var/lib/puppet/lib/facter/netns_support.rb
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter glance_user_password at /opt/rh/ruby193/root/etc/puppet/environments/production/modules/quickstack/manifests/controller.pp:99 on node puma02.scl.lab.tlv.redhat.com
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
Comment 2 Omri Hochman 2013-08-18 04:06:02 EDT
After downgraded to older packstack-modules-puppet:  (packstack-modules-puppet-2013.1.1-0.23.dev642.el6ost.noarch)

And re-installed the-foreman machine, the installation of 'controller' using the-foreman with the older packstack-modules-puppet worked fine.
Comment 3 Charles Crouch 2013-08-22 15:47:06 EDT
From ohochman:
"The issue #993642 reproduces on the latest puddle 2013-08-20.1, rhos3.0.z2 , with packstack-modules-puppet-2013.1.1-0.30,

I think it should be fixed for next build, even if foreman is a tech-preview in rhos3.0,  

Martin: Note that with packstack-modules-puppet-2013.1.1-0.23.dev642.el6ost.noarch - it worked fine."
Comment 4 Charles Crouch 2013-08-22 15:49:27 EDT
Setting component and target milestone correctly.
Comment 5 Charles Crouch 2013-08-22 16:03:49 EDT
Setting blocker flag since ohochman isn't here to do it.

This is certainly a regression from rhos3.0, customers can no longer install an OpenStack controller node via Foreman. I don't know if this impacts the triage but Foreman is Tech Preview in RHOS3, but this change in the underlying glance puppet modules has effectively rendered Foreman useless out of the box.
Comment 9 Bruce Reeler 2013-08-28 02:31:41 EDT
NEEDINFO for Jordan O'Mara

I am writing the Doc Text for bug advisories. As the Doc Text field was blank, I have written the current Doc Text from scratch. Could you please comment or edit it and correct as necessary. Thanks.
Comment 10 Omri Hochman 2013-08-28 08:11:34 EDT
Verified - with  : ruby193-openstack-foreman-installer-0.0.18-3.el6ost.x86_64 (puddle 2013-08-27.1)
Deployment of 'controller' using openstack-foreman works fine.
Comment 11 Bruce Reeler 2013-08-29 02:57:41 EDT
Doc Text left as-is after consulting with Jordan O'Mara.
Comment 13 errata-xmlrpc 2013-09-03 15:58:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1186.html

Note You need to log in before you can comment on or make changes to this bug.