Bug 993651 - Teiid Designer cannot connect to remote ModeShape server
Teiid Designer cannot connect to remote ModeShape server
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
All All
unspecified Severity high
: ER2
: 6.0
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 07:12 EDT by Horia Chiorean
Modified: 2016-02-10 03:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:57:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2003 Blocker Closed JcrDriver Is Missing A No Arg Constructor 2014-07-17 03:08:32 EDT

  None (edit)
Description Horia Chiorean 2013-08-06 07:12:46 EDT
Teiid Designer cannot connect via the remote JDBC driver to a running ModeShape server, because the ModeShape JDBC driver lacks a public, no-arg constructor, preventing the JDBC Driver Manager from instantiating it.

The raised exception is:
java.lang.InstantiationException: org.modeshape.jdbc.JcrDriver
  at java.lang.Class.newInstance0(Class.java:342)
  at java.lang.Class.newInstance(Class.java:310)
  at org.teiid.designer.datatools.profiles.modeshape.ModeShapeJDBCConnection.createConnection(ModeShapeJDBCConnection.java:43)
JcrDriver does not have a no arg constructor
Comment 2 JBoss JIRA Server 2013-08-06 07:44:33 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2003

Added no-arg constructor back to JcrDriver.
Comment 4 JBoss JIRA Server 2013-08-06 15:31:53 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2003

Rebased, and merged into the 'master' branch.
Comment 10 JBoss JIRA Server 2013-10-24 05:21:50 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2003 to Closed
Comment 11 belong 2013-11-19 18:15:14 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 12 Filip Nguyen 2014-02-12 03:23:28 EST
Successfully connected in GA to the MS via JcrDriver. The JDBS retrieved "dv" repository.

Note You need to log in before you can comment on or make changes to this bug.