Bug 993750 - [abrt] fros-1.0-1.fc19: fros:72:<module>:IndexError: list index out of range
[abrt] fros-1.0-1.fc19: fros:72:<module>:IndexError: list index out of range
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fros (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
abrt_hash:37bc4015d924f46bbc99e954f82...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 08:05 EDT by Kamil Páral
Modified: 2016-11-30 19:44 EST (History)
2 users (show)

See Also:
Fixed In Version: fros-1.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 03:57:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2013-08-06 08:05 EDT, Kamil Páral
no flags Details
File: environ (3.00 KB, text/plain)
2013-08-06 08:05 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-08-06 08:05:49 EDT
Description of problem:
Just run 'fros'

Version-Release number of selected component:
fros-1.0-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/fros
executable:     /usr/bin/fros
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
fros:72:<module>:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/fros", line 72, in <module>
    info("Selected plugin: ", available_plugins[0])
IndexError: list index out of range

Local variables in innermost frame:
info: <function info at 0x7fca0d218578>
argparse: <module 'argparse' from '/usr/lib64/python2.7/argparse.pyc'>
commands: ArgumentParser(prog='parent', usage=None, description='Screencasting cmdline', version=None, formatter_class=<class 'argparse.HelpFormatter'>, conflict_handler='error', add_help=True)
args: Namespace(is_available=False, verbose=0)
const: <module 'pyfros.plugins.const' from '/usr/lib/python2.7/site-packages/pyfros/plugins/const.pyc'>
load_plugins: <function load_plugins at 0x12d7578>
__builtins__: <module '__builtin__' (built-in)>
__file__: '/usr/bin/fros'
Gtk: <gi.module.DynamicModule 'Gtk' from '/usr/lib64/girepository-1.0/Gtk-3.0.typelib'>
available_plugins: []
Controls: <class 'pyfros.controls.Controls'>
__package__: None
sys: <module 'sys' (built-in)>
PLUGIN_DIR: '.'
plugins: <module 'pyfros.plugins' from '/usr/lib/python2.7/site-packages/pyfros/plugins/__init__.pyc'>
i18n: <module 'pyfros.i18n' from '/usr/lib/python2.7/site-packages/pyfros/i18n.pyc'>
__name__: '__main__'
set_verbosity: <function set_verbosity at 0x7fca144149b0>
__doc__: None
_: <function lgettext at 0x7fca0c0f3410>
Comment 1 Kamil Páral 2013-08-06 08:05:53 EDT
Created attachment 783293 [details]
File: backtrace
Comment 2 Kamil Páral 2013-08-06 08:05:56 EDT
Created attachment 783294 [details]
File: environ
Comment 3 Kamil Páral 2013-08-06 08:06:49 EDT
*** Bug 993619 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Admin XMLRPC Client 2013-11-13 03:48:18 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Jakub Filak 2013-11-13 03:57:19 EST
fros-1.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.