Bug 993787 - BRMS distribution possibly missing certain droolsjbpm artifacts
BRMS distribution possibly missing certain droolsjbpm artifacts
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Kris Verlaenen
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 08:15 EDT by Lukáš Petrovický
Modified: 2014-08-06 16:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukáš Petrovický 2013-08-06 08:15:06 EDT
Drools+jBPM project contain a lot of Maven modules, many of which provide JAR artifacts. Of these, the following are not present in BRMS:

The following are probably OK to be missing:

jbpm-human-task-core
jbpm-human-task-workitems
jbpm-form-services
jbpm-executor
jbpm-runtime-manager
optaplanner-webexamples
drools-examples
drools-examples-api
drools-examples-cdi
drools-maven-plugin
jbpm-examples
drools-benchmark
drools-camel-server-example
droolsjbpm-osgi-examples
droolsjbpm-integration-examples

For the following, we will have to make a decision whether to include them or not:
           
drools-jsr94
jbpm-shared-services
jbpm-kie-services
knowledge-api-legacy5-adapter
jbpm-test
jbpm-audit
drools-spring-legacy5
drools-camel-legacy5
drools-karaf-features
drools-karaf-itest
drools-rhq-plugin
kie-services-client
kie-services-remote
kie-aries-blueprint
drools-jboss-integration
drools-osgi-integration
Comment 2 Lukáš Petrovický 2013-08-28 08:55:22 EDT
On top of the above, ER2 is missing:

drools-verifier
Comment 4 Rajesh Rajasekaran 2013-10-29 16:41:58 EDT
Is this issue still relevant with ER4?
Comment 5 Lukáš Petrovický 2013-10-30 04:21:59 EDT
Yes. No work has been done here; we should start by deciding whether or not we want those JARs shipped and supported.
Comment 7 Geoffrey De Smet 2013-10-30 05:06:51 EDT
The optaplanner zip should have directory examples and a directory webexamples. In the webexamples directory, the optaplanner-webexamples-*.war should be present.
Comment 8 Ryan Zhang 2013-10-30 05:15:19 EDT
Geoffrey, in ER4, the example and webexamples had been fixed.
(In reply to Geoffrey De Smet from comment #7)
> The optaplanner zip should have directory examples and a directory
> webexamples. In the webexamples directory, the optaplanner-webexamples-*.war
> should be present.
Comment 9 Pedro Zapata 2013-10-31 12:20:54 EDT
Current list of inclusions / exclusions 

Include:
==================================

kie-maven-plugin  @ org.kie

drools-karaf-features     @ org.drools.integration 
drools-karaf-itest	  @ org.drools.integration
drools-rhq-plugin         @ org.drools.integration
drools-jboss-integration  @ org.drools.integration
drools-osgi-integration   @ org.drools.integration
kie-aries-blueprint       @ org.drools.integration

knowledge-api-legacy5-adapter @org.drools

- Optaplanner jars        @ org.optaplanner



Exclude:
=================================
jbpm-human-task-core
jbpm-human-task-workitems
jbpm-form-services
jbpm-executor
jbpm-runtime-manager
jbpm-shared-services
jbpm-kie-services
jbpm-test
jbpm-audit
kie-services-client
kie-services-remote
optaplanner-webexamples
drools-examples
drools-examples-api
drools-examples-cdi
jbpm-examples
drools-benchmark
drools-camel-server-example
droolsjbpm-osgi-examples
droolsjbpm-integration-examples
Comment 11 Pedro Zapata 2013-11-04 10:22:15 EST
Binary distributions must be updated before modules (if finally needed)
Comment 13 Lukáš Petrovický 2013-11-25 04:47:02 EST
The following JARs are not present in BRMS 6.0 ER5:

knowledge-api-legacy5-adapter
drools-spring-legacy5
drools-camel-legacy5
kie-services-client
kie-services-remote
drools-jboss-integration

If we are OK with this, this issue can be resolved.
Comment 14 Kris Verlaenen 2013-11-25 10:34:00 EST
This seems to be correct:

knowledge-api-legacy5-adapter
--> this is the knowledge-api jar, which seems to be included
drools-spring-legacy5
drools-camel-legacy5
--> should not be included as they are replaced with other jars
kie-services-client
kie-services-remote
--> should not be included, is part of BPMS only
drools-jboss-integration
--> should not be included, is a test jar
Comment 15 Lukáš Petrovický 2013-11-25 10:36:17 EST
In that case, VERIFIED with ER5.

Note You need to log in before you can comment on or make changes to this bug.