Bug 993827 - R 3.0.1 breaks bindings for Python 2.6
R 3.0.1 breaks bindings for Python 2.6
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: R (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
http://www.sysarchitects.com/installi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 08:28 EDT by Robert Buchholz
Modified: 2013-08-16 10:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 10:46:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Buchholz 2013-08-06 08:28:06 EDT
The EPEL R package went from 2.15 to 3.0, breaking the Python bindings (which are not part of RHEL or EPEL).
Rpy2 2.2.X is the last version to support Python 2.6, but breaks with R 3.0
Rpy2 2.3.X supports only Python 2.7 and newer, and works with R 3.0

So this recent upgrade makes the combination of system Python and system R unusable. It was my understanding that EPEL packages will not change major versions / API between updates.
Comment 1 Tom "spot" Callaway 2013-08-16 10:46:09 EDT
I definitely see the concern here. Rpy isn't actually part of EPEL, which is why I didn't see this when I originally did this work.

The problem is that the number of people who want to use R3 on RHEL outnumbers those using the optional Python bindings.

One workaround might be to get the python27 package into EPEL:

https://bugzilla.redhat.com/show_bug.cgi?id=829892

At this point, I can't really back out R3 on EL6, so I'm forced to close this CANTFIX. Thanks for your excellent writeup on how to manually update Python.

Note You need to log in before you can comment on or make changes to this bug.