Bug 993911 - Can't edit a test case
Can't edit a test case
Status: CLOSED CURRENTRELEASE
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yang Ren
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 09:08 EDT by Radek Bíba
Modified: 2016-09-30 07:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-30 07:55:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2013-08-06 09:08:13 EDT
Description of problem:
I'm unable to save my changes to the Actions textarea in this test case:

https://tcms.engineering.redhat.com/case/77009/edit/?from_plan=652

When I click Save (or any of the other buttons), TCMS says:

Welcome, Guest (which is strange because I use kerberos credentials)
...
    Sorry, This is a service error.
    1.Please check your operation , try it again;
    2.You can contact the administrator or developer.
    GO BACK



Version-Release number of selected component (if applicable):
Nitrate 3.8.2

How reproducible:
Always with this test case.
Comment 1 Radek Bíba 2013-08-07 04:42:40 EDT
Additional information:

1 - I can edit other test cases.
2 - I can use the exact contents of the Actions textarea in another edited test case.
3 - The same error occurs when I try saving a very simple piece of text in the affected test case.
4 - The test case metadata look correct.
5 - My peer gets the same error when he tries saving the test case.
Comment 2 jianchen 2013-08-07 05:12:30 EDT
For no affect the work, a temporary solution to is clone this case and re-edit. 
It's seems only the case raise 500 error when click "save" button.
Comment 3 Radek Bíba 2013-08-07 05:22:41 EDT
I'm CCing Petr, the owner/author of the test case.

Petr, please check if you can edit it. If not, I guess we could clone it and discard the old one, but I'll leave that up to you because the old one is used in many places, AFAIK.
Comment 4 Petr Šplíchal 2013-08-15 08:37:04 EDT
I believe the error appears when the default tester is set to
"nobody". I tried to change it back to myself and then was able
to edit and save changes of this test case successfully.
Comment 5 Radek Bíba 2013-08-15 08:56:23 EDT
Great, I can edit the test case again, too.

Now please fix TCMS. :)
Comment 6 Tingting Zhao 2014-07-22 01:59:27 EDT
Verify on Product with nitrate version 3.8.8----->pass
steps are the same as the description.

Note You need to log in before you can comment on or make changes to this bug.