Bug 994009 - ABRT doesn't appear in GNOME Control Center's notification panel
ABRT doesn't appear in GNOME Control Center's notification panel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 09:46 EDT by Mathieu Bridon
Modified: 2016-11-30 19:44 EST (History)
8 users (show)

See Also:
Fixed In Version: libreport-2.1.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 08:51:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Bridon 2013-08-06 09:46:03 EDT
Description of problem:
Open GNOME Control Center, go to the « Notifications » panel. ABRT is not in the list.


Version-Release number of selected component (if applicable):
abrt-2.1.6-2.fc19.x86_64


All that should be needed to do is this:
https://wiki.gnome.org/GnomeGoals/NotificationSource
Comment 1 Jakub Filak 2013-08-09 04:06:59 EDT
Patches fixing this bug report has been submitted for review:
https://lists.fedorahosted.org/pipermail/crash-catcher/2013-August/005160.html
Comment 2 Jakub Filak 2013-08-09 06:40:36 EDT
Fixed in upstream git:

commit 883c74b35e2e33d061841222b3445d697399193a
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Aug 9 09:04:52 2013 +0200

    spec: install applet's desktop file to system dir
    
    Closes rhbz#994009
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Richard Marko <rmarko@redhat.com>

commit b73219d0bf8d735aaac030a000124bffb3655a6a
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Aug 9 09:04:51 2013 +0200

    applet: configure notification source
    
    The desktop file will be installed to /usr/share/applications. All
    destkop files in the applications directory are displayed in user menus
    but abrt-applet is not intended to be started by users. Therefore
    NoDisplay entry is used to prevent displaying applet in the
    menus.
    
    Related to rhbz#994009
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Richard Marko <rmarko@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.