Bug 994202 - yum selects both ruby and jruby, because the latter provides ruby(version)
yum selects both ruby and jruby, because the latter provides ruby(version)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: h2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 13:51 EDT by Matthew Miller
Modified: 2013-08-06 13:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 13:53:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2013-08-06 13:51:03 EDT
The puppet package in Fedora has a "Requires: ruby(version)" as required by the packaging guidelines.  However, we really want it to use the normal Ruby MRI package, not least because jruby has tons of dependencies. So, again following the guidelines, an explicit "Requires: ruby" was added. However, this does not solve the problem. From a minimal install when one runs `yum install ruby`, one gets both!

This is because jruby is first selected to provide the ruby(version) dependency, and then ruby is added latter:

--> Processing Dependency: ruby(release) for package: puppet-3.1.1-5.fc19.noarch
Searching pkgSack for dep: ruby(release)
TSINFO: Marking jruby-1.7.2-1.fc19.noarch as install for puppet-3.1.1-5.fc19.noarch
[...]
--> Processing Dependency: ruby for package: puppet-3.1.1-5.fc19.noarch
Searching pkgSack for dep: ruby
TSINFO: Marking ruby-2.0.0.247-14.fc19.x86_64 as install for puppet-3.1.1-5.fc19.noarch


Of course, `ruby` could satisfy both dependencies, and that's the desired outcome.



Using yum-3.4.3-104.fc19.noarch, with current Fedora (package versions as above).
Comment 1 Matthew Miller 2013-08-06 13:53:16 EDT
Um, not sure how this got created as "h2" -- sorry. And I can't change it for some awesome reason.

Note You need to log in before you can comment on or make changes to this bug.