Bug 994207 - QuickStack manifests out of date after packstack update
QuickStack manifests out of date after packstack update
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
3.0
Unspecified Unspecified
medium Severity high
: beta
: 4.0
Assigned To: Crag Wolfe
Ami Jeain
:
Depends On:
Blocks: 1034364
  Show dependency treegraph
 
Reported: 2013-08-06 14:04 EDT by Jordan OMara
Modified: 2014-11-09 17:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1034364 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:17:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan OMara 2013-08-06 14:04:05 EDT
On line 99 of quickstack/manifests/controller.pp, the glance parameter names have changed

glance_user_password  => $glance_user_password,
glance_db_password    => $glance_db_password,


Become:
user_password  => $glance_user_password,
db_password    => $glance_db_password,

This affects versions of packstack >= -651
Comment 2 Crag Wolfe 2013-08-06 21:35:11 EDT
A new rpm is available in brew with the fix, ruby193-openstack-foreman-installer-0.0.18-3.el6ost.
Comment 3 Crag Wolfe 2013-11-13 13:09:43 EST
Confirmed that this fix is publicly available now (same version as mentioned in above comment).
Comment 4 Crag Wolfe 2013-11-13 13:21:46 EST
Also, this change has been upstream in redhat-openstack/astapor for quite awhile so action needed for rhos4.0.
Comment 5 Scott Lewis 2013-11-19 11:54:23 EST
Auto adding >= MODIFIED bugs to beta
Comment 6 Ami Jeain 2013-11-24 09:24:16 EST
class { 'openstack::glance':
    debug            => $debug,
    verbose          => $verbose,
    db_type          => $db_type,
    db_host          => $db_host,
    db_ssl           => $mysql_ssl,
    db_ssl_ca        => $mysql_ca,
    sql_idle_timeout => $sql_idle_timeout,
    keystone_host    => $keystone_host,
    registry_host    => $glance_registry_host,
    db_user          => $glance_db_user,
    db_name          => $glance_db_dbname,
    db_password      => $glance_db_password,
    user_password    => $glance_user_password
Comment 11 errata-xmlrpc 2013-12-19 19:17:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.