Bug 994236 - cpucycles.o and randombytes.o missing
cpucycles.o and randombytes.o missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nacl (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 16:05 EDT by Frederik Holden
Modified: 2014-10-23 02:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: nacl-20110221-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-23 02:22:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 694248 None None None Never

  None (edit)
Description Frederik Holden 2013-08-06 16:05:41 EDT
Description of problem:
The object files cpucycles.o and randombytes.o are missing from libdir. The spec only installs build/fedora/lib/*/*.a, while it should also be including build/fedora/lib/*/*.o.

Version-Release number of selected component (if applicable):
20110221-5.fc19

Actual results:
Missing cpucycles.o and randombytes.o.

Expected results:
cpycycles.o and randombytes.o in libdir.

Additional info:
The Debian package is also missing these files. I don't know why. I've included the Debian bug ID with this bug report in case it is in some way relevant.
Comment 1 Jaroslav Škarvada 2013-08-08 08:51:50 EDT
Thanks for the report. It makes sense to me, I am fixing it in f19 - f20. I noticed the debian maintainer already notified the upstream, so I am not forwarding it again.
Comment 2 Fedora Update System 2013-08-08 09:31:55 EDT
nacl-20110221-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nacl-20110221-7.fc19
Comment 3 Fedora Update System 2013-08-09 13:03:36 EDT
Package nacl-20110221-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nacl-20110221-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14468/nacl-20110221-7.fc19
then log in and leave karma (feedback).
Comment 4 JannikV 2013-08-11 12:29:21 EDT
Is libnacl.a really the right place for cpucycles.o and randombytes.o ?
I'm not sure because the "Files" section on this site ( http://petio.org/tools/nacl.html ) shows that libnacl.a, cpucycles.o and randombytes.o are placed together in the library dir. I have also seen some projects which are looking for the two .o files in the library dir instead of using libnacl.a.

Only wanted to note that, maybe you are right.
Comment 5 Jaroslav Škarvada 2013-08-12 04:15:37 EDT
(In reply to JannikV from comment #4)
Thanks for info. For me it seems strange to have there archive and two separate objects which are also deps for objects in the archive. But I am watching the debian bug and waiting for the upstream reply - no problem to change it.
Comment 6 Jaroslav Škarvada 2013-08-19 04:38:18 EDT
(In reply to Jaroslav Škarvada from comment #5)
> (In reply to JannikV from comment #4)
By reading the upstream reply I suppose they prefer the objects to be outside of the archive. I am changing it this way.
Comment 7 Fedora Update System 2013-08-19 17:23:54 EDT
Package nacl-20110221-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nacl-20110221-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14468/nacl-20110221-8.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-10-23 02:22:59 EDT
nacl-20110221-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.