Bug 994274 - please remove -grecord-gcc-switches in "macros"
please remove -grecord-gcc-switches in "macros"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 19:30 EDT by Mr-4
Modified: 2013-08-07 02:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 02:43:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mr-4 2013-08-06 19:30:56 EDT
Description of problem:
When using rpmbuild with older gcc versions (4.4.x, 4.5.x etc) the compiler cannot produce executables.

Version-Release number of selected component (if applicable):
9.1.0

How reproducible:
always

Steps to Reproduce:
1. rpmbuild -bb <spec_file>
2.
3.

Actual results:
An error is produced during configure/compile state due to the wrong option used as indicated above.

Expected results:
No errors to be produced.

Additional info:
This is produced as a result of the inclusion of "-grecord-gcc-switches" option in the %__global_cflags macro included in "macros", which is NOT a valid gcc option on older version of the compiler. Please remove it.
Comment 1 Panu Matilainen 2013-08-07 02:43:44 EDT
The default compilation flags in redhat-rpm-config are strictly for the gcc shipped with the distro only. If you want to compile with something else you need to set your own defaults.

Note You need to log in before you can comment on or make changes to this bug.