Bug 994279 - IOException: Input/output error during write on /dev/sda
IOException: Input/output error during write on /dev/sda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:06d631f0200b404061eb6f9967f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 20:06 EDT by cleaver.xero
Modified: 2013-08-07 16:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 10:22:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (986.25 KB, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: anaconda.log (11.14 KB, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: environ (440 bytes, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: lsblk_output (2.72 KB, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: messages (648.54 KB, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: nmcli_dev_list (5.55 KB, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: os_info (179 bytes, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: program.log (61.13 KB, text/plain)
2013-08-06 20:06 EDT, cleaver.xero
no flags Details
File: storage.log (255.38 KB, text/plain)
2013-08-06 20:07 EDT, cleaver.xero
no flags Details
File: ifcfg.log (576 bytes, text/plain)
2013-08-06 20:07 EDT, cleaver.xero
no flags Details

  None (edit)
Description cleaver.xero 2013-08-06 20:06:19 EDT
Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 221, in commitToDevice
    return self.__disk.commit_to_dev()
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/formats/disklabel.py", line 304, in commitToDisk
    self.partedDisk.commitToDevice()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 363, in doIt
    dev.disk.format.commitToDisk()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
IOException: Input/output error during write on /dev/sda

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64, pyparted-3.9-3.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 cleaver.xero 2013-08-06 20:06:29 EDT
Created attachment 783569 [details]
File: anaconda-tb
Comment 2 cleaver.xero 2013-08-06 20:06:33 EDT
Created attachment 783570 [details]
File: anaconda.log
Comment 3 cleaver.xero 2013-08-06 20:06:37 EDT
Created attachment 783571 [details]
File: environ
Comment 4 cleaver.xero 2013-08-06 20:06:41 EDT
Created attachment 783572 [details]
File: lsblk_output
Comment 5 cleaver.xero 2013-08-06 20:06:48 EDT
Created attachment 783573 [details]
File: messages
Comment 6 cleaver.xero 2013-08-06 20:06:52 EDT
Created attachment 783574 [details]
File: nmcli_dev_list
Comment 7 cleaver.xero 2013-08-06 20:06:56 EDT
Created attachment 783575 [details]
File: os_info
Comment 8 cleaver.xero 2013-08-06 20:06:59 EDT
Created attachment 783576 [details]
File: program.log
Comment 9 cleaver.xero 2013-08-06 20:07:04 EDT
Created attachment 783577 [details]
File: storage.log
Comment 10 cleaver.xero 2013-08-06 20:07:10 EDT
Created attachment 783578 [details]
File: ifcfg.log
Comment 11 David Shea 2013-08-07 10:22:03 EDT
There are a lot of log entries from the kernel in the messages like:

Aug  6 20:03:07 localhost kernel: [  133.883947] ata1.00: exception Emask 0x0 SAct 0x7fffffff SErr 0x0 action 0x6 frozen
Aug  6 20:03:07 localhost kernel: [  133.883956] ata1.00: failed command: WRITE FPDMA QUEUED
Aug  6 20:03:07 localhost kernel: [  133.883964] ata1.00: cmd 61/00:00:00:10:ff/04:00:36:00:00/40 tag 0 ncq 524288 out
Aug  6 20:03:07 localhost kernel: [  133.883964]          res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)

and

Aug  6 20:04:07 localhost kernel: [  194.072167] sd 0:0:0:0: [sda] Unhandled error code
Aug  6 20:04:07 localhost kernel: [  194.072171] sd 0:0:0:0: [sda]  
Aug  6 20:04:07 localhost kernel: [  194.072173] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Aug  6 20:04:07 localhost kernel: [  194.072176] sd 0:0:0:0: [sda] CDB: 
Aug  6 20:04:07 localhost kernel: [  194.072178] Write(10): 2a 00 36 ff 0c 00 00 04 00 00
Aug  6 20:04:07 localhost kernel: [  194.072188] end_request: I/O error, dev sda, sector 922684416
Aug  6 20:04:07 localhost kernel: [  194.072195] Buffer I/O error on device dm-2, logical block 6346624
Aug  6 20:04:07 localhost kernel: [  194.072197] lost page write due to I/O error on dm-2


Your hard drive appears to be failing.
Comment 12 Steve Tyler 2013-08-07 16:01:34 EDT
Aug  6 20:01:12 localhost kernel: [    2.681253] ata1.00: ATA-8: TOSHIBA MK5056GSY, LH003D, max UDMA/100

The smartctl command will give you SMART disk status. You can install and run it from the Live environment:

$ sudo yum install smartmontools -y
$ sudo smartctl -H /dev/sda
http://smartmontools.sourceforge.net/

Contacting Toshiba for disk diagostics would be even better.

Note You need to log in before you can comment on or make changes to this bug.