This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 994285 - Release 2 install on CentOS 6 cannot compile CSS
Release 2 install on CentOS 6 cannot compile CSS
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 21:07 EDT by steven.merrill
Modified: 2015-05-14 21:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:21:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to fix the console assets issue. (361 bytes, text/plain)
2013-08-06 21:07 EDT, steven.merrill
no flags Details

  None (edit)
Description steven.merrill 2013-08-06 21:07:27 EDT
Created attachment 783579 [details]
A patch to fix the console assets issue.

Description of problem:

On a fresh install of OpenShift Origin Release 2 to CentOS 6, the console cannot be visited because of this exception:

---
Sass::SyntaxError in Application_types#index

Showing /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-console-1.13.0.1/app/views/layouts/console/_stylesheets.html.haml where line #2 raised:

File to import not found or unreadable: twitter/variables.
Load paths:
  Sass::Rails::Importer(/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-console-1.13.0.1/app/assets/stylesheets/common.css.scss)
  /var/www/openshift/console/app/assets/stylesheets
  /opt/rh/ruby193/root/usr/share/gems/gems/compass-0.12.2/frameworks/blueprint/stylesheets
  /opt/rh/ruby193/root/usr/share/gems/gems/compass-0.12.2/frameworks/compass/stylesheets
  Compass::SpriteImporter
  (in /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-console-1.13.0.1/app/assets/stylesheets/common.css.scss)
Extracted source (around line #2):

1: -# CSS: implied media="all"
2: = stylesheet_link_tag 'common.css', :media => 'all'
3: = stylesheet_link_tag 'origin.css', :media => 'all'
4: 
5: -# Append your own using content_for :stylesheets
Trace of template inclusion: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-console-1.13.0.1/app/views/layouts/console.html.haml

Rails.root: /var/www/openshift/console
---

Version-Release number of selected component (if applicable):

Release 2, installed on August 6, 2013.

How reproducible:

Install OpenShift Origin Release 2 on CentOS or RHEL using the Puppet script and the following site.pp:

class { 'openshift_origin' :
  node_fqdn                  => "${::hostname}.${::domain}",
  cloud_domain               => "${::domain}",
  dns_servers                => ['8.8.8.8'],
  os_unmanaged_users         => [],
  enable_network_services    => true,
  configure_firewall         => true,
  configure_ntp              => true,
  configure_activemq         => true,
  configure_mongodb          => true,
  configure_named            => true,
  configure_avahi            => false,
  configure_broker           => true,
  configure_node             => true,
  development_mode           => true,
  update_network_dns_servers => true,

  configure_qpid             => true,
  named_tsig_priv_key        => "**snipped**",
  install_repo               => "https://mirror.openshift.com/pub/openshift-origin/release/2/rhel-6/packages/${::architecture}/",
}

Reboot the machine.
Go to the broker.
Get the exception.

Steps to Reproduce:
1. Run Puppet to install release 2 on RHEL / CentOS 6.
2. Reboot.
3. Go to the console.
4. Get the exception.

Actual results:

An exception.

Expected results:

Seeing the console.

Additional info:

This issue can be solved by adding the attached patch to /var/www/openshift/console and restarting the openshift-console service.
Comment 1 steven.merrill 2013-08-06 21:10:25 EDT
The fix for this issue appears to already be on git master at https://github.com/openshift/origin-server/blob/master/console/Gemfile#L32 .
Comment 2 Clayton Coleman 2013-08-19 16:05:55 EDT
Krishna, agree this should be fixed upstream.
Comment 3 Krishna Raman 2013-08-21 13:53:59 EDT
Fix pushed to origin release 2 branch and new RPMs have been compiled and posted.
Comment 4 Yujie Zhang 2013-11-15 05:24:56 EST
Verify this bug since the fix code has pushed to origin server master, thanks.
Comment 5 Yujie Zhang 2013-11-15 05:39:34 EST
The console can work correctly now, thanks.

Note You need to log in before you can comment on or make changes to this bug.