Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 994373 - jBPM engine does not support multiple incoming flow into end event node
jBPM engine does not support multiple incoming flow into end event node
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Maciej Swiderski
Radovan Synek
:
: 975935 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 03:01 EDT by Radovan Synek
Modified: 2014-08-06 16:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
process definition (13.89 KB, application/xml)
2013-08-07 03:01 EDT, Radovan Synek
no flags Details
error stacktrace (4.63 KB, text/x-log)
2013-08-07 03:01 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-07 03:01:19 EDT
Created attachment 783693 [details]
process definition

Take a look at the attached process definition. It was created and validated in jBPM Designer - and as far as I know it's a valid bpmn2 definition. However, when I tried to build a project containing this definition, exception appeared in the server log (attaching the stacktrace).
Comment 1 Radovan Synek 2013-08-07 03:01:52 EDT
Created attachment 783694 [details]
error stacktrace
Comment 2 Kris Verlaenen 2013-08-07 10:18:55 EDT
Note that support for multiple incoming our outgoing connections for all nodes other than gateways are currently not supported (as best practice).  Support for multiple connections can be enabled however using system parameter: -Djbpm.enable.multi.con=true

See also https://issues.jboss.org/browse/JBPM-3372

Could you verify this issue still exists when using that parameter?

Tiho, would it be possible to have designer validate processes taking this system parameter into account (so signaling process definitions with multiple incoming / outgoing connections as invalid if this parameter is not set to true)?
Comment 3 Radovan Synek 2013-08-08 03:54:55 EDT
I can see the problem even when using the property - see the pull request https://github.com/droolsjbpm/jbpm/pull/176
Comment 4 Maciej Swiderski 2013-08-15 06:11:28 EDT
EndNode does not check the property to allow multiple incoming connection, I'll fix it
Comment 6 Radovan Synek 2013-09-04 03:44:47 EDT
Verified on BPMS 6.0.0.ER2
Comment 10 Sona Mala 2013-12-19 10:04:33 EST
*** Bug 975935 has been marked as a duplicate of this bug. ***
Comment 11 Radovan Synek 2014-03-18 12:09:09 EDT
qe_test_coverage: covered by community unit tests

Note You need to log in before you can comment on or make changes to this bug.