Bug 994394 - Qemu monitor "system_powerdown" command does not work for ubuntu.12.04 guest
Qemu monitor "system_powerdown" command does not work for ubuntu.12.04 guest
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 04:07 EDT by ShupingCui
Modified: 2016-05-16 00:06 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 02:07:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ShupingCui 2013-08-07 04:07:11 EDT
Description of problem:
Qemu monitor "system_powerdown" command does not work for ubuntu.12.04 guest

Version-Release number of selected component (if applicable):
Host:
# uname -r
2.6.32-402.el6.x86_64
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-0.12.1.2-2.382.el6.x86_64

Guest:
# uname -r
3.2.0-23-generic

How reproducible:
100%

Steps to Reproduce:
1. boot the ubuntu guest
/usr/libexec/qemu-kvm \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/ubuntu-12.04-server-64-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device virtio-net-pci,netdev=idxlu4ZI,mac='9a:01:02:03:04:05',bus=pci.0,addr=0x3,id='idOZ6MbI' \
    -netdev tap,id=idxlu4ZI,vhost=on \
    -m 4096 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G3' \
    -M rhel6.5.0 \
    -device AC97,addr=0x6 \
    -vnc :0 \
    -vga cirrus \
    -global qxl-vga.vram_size=33554432 \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off   \
    -no-kvm-pit-reinjection \
    -enable-kvm \
    -monitor stdio

2. execute "system_powerdown" command after the guest boot up
(qemu) system_powerdown 
wait 1 min
(qemu) info status 
VM status: running

3.

Actual results:
guest cannot shutdown

Expected results:
guest shutdown successful

Additional info:
1. tested qemu-kvm-rhev-0.12.1.2-2.384.el6.x86_64, hit same problem
2. tested rhel guest, guest shutdown successful after execute "system_powerdown" command
Comment 2 Xiaoqing Wei 2013-08-07 05:04:02 EDT
Hi Shuping,

pls update rhel guest behaviour here and, set the priority/serverity,

Thanks
Xiaoqing.
Comment 5 Amit Shah 2013-08-08 02:11:44 EDT
The best way to check a guest's behaviour for acpi shutdown is to boot the same OS on a physical host, and in the same state (i.e. logged into desktop or just waiting at login screen), hit the power button and see what happens.  If the same behaviour is shown when the OS is running as a guest, we don't have any problem.

However, in general, for shutdown, reboot, etc., to work, we have to rely on the guest agent.
Comment 6 Suqin Huang 2013-08-08 02:56:20 EDT
scui,
According to comment5, can you try it on host, can provide the screenshort where the guest stay.
Comment 7 ShupingCui 2013-08-14 02:07:11 EDT
According to comment3 and comment5, not found acpi module in guest. Qemu monitor "system_powerdown" command works fine when i install the acpi module. So it's not a bug, close it.

Note You need to log in before you can comment on or make changes to this bug.