Bug 994416 - Software Update has empty window without feedback.
Software Update has empty window without feedback.
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 05:03 EDT by Jan Vlug
Modified: 2016-02-04 12:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:37:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Vlug 2013-08-07 05:03:56 EDT
When I start gpk-update-viewer --verbose the Software Update window shows up empty. There is no user feedback, also not on the console.
I am behind a proxy, but usually, the software updates via gpk-update-viewer work correctly. Could it be that gpk-update-viewer hangs on a network timeout?
If I check with yum update, I see that there are updates available.
I'm using: gnome-packagekit-3.8.2-2.fc19.x86_64
Comment 1 Jan Vlug 2013-08-07 05:11:17 EDT
When I run gpk-update-viewer as root it works without problems.

Note that the only line that I get when running gpk-update-viewer as a normal user is:
11:05:50	GnomePackageKit     Verbose debugging enabled (on console 1)
Comment 2 Jan Vlug 2013-08-07 07:10:05 EDT
After a reboot gpk-update-viewer works correctly again. But I've seen this problem more often. If it happens again, I will update this bug. Let me know if you want me to performs some tests when it happens again.
Comment 3 Jan Vlug 2013-08-09 13:09:23 EDT
It happened again. This was after that I did a software update which prompted met to log out and log in again. When I tried to update again (before having been logged out) I got the blank window again.
After logging out and in again, the software updater worked correctly.
Comment 4 Jan Vlug 2013-08-10 09:13:14 EDT
The proxy part in the description is irrelevant. I have the issue now on a host that is not behind a proxy as well. After an update, gpk-update-viewer prompted met that I had to do a reboot. I did not do that. Started gpk-update-viewer again, and have the blank screen. Again, when run as root gpk-update-viewer works fine, and prompts met that all software is up-to-date.
Comment 5 Jan Vlug 2013-08-12 06:33:30 EDT
Interestingly enough, today, I did a large update again that prompted me to reboot. Before rebooting, I started gpk-update-viewer to test whether it would produce the blank window, and now it works fine i.e. I do not get the blank window, but the Software Update window with a pop-up window stating: "All software is up to date".
Comment 6 Chris Morgan 2013-09-08 10:08:45 EDT
Seeing the same behavior here. gpk-update-viewer starts up but has a blank window.
Comment 7 Sylvain Petreolle 2014-09-19 13:56:03 EDT
Hello, I get the same problem with Fedora 20.
I'm not behind a proxy and launching gpk-update-viewer with sudo makes it work.
pkcon refresh get-updates shows updates.
Comment 8 Fedora End Of Life 2015-01-09 14:20:10 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2015-02-17 11:37:44 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.