Bug 994420 - RTGov does not work with JCA gateway
RTGov does not work with JCA gateway
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: ---
Assigned To: Gary Brown
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 05:09 EDT by Jiri Pechanec
Modified: 2015-08-02 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-08-07 05:09:01 EDT
Try jca-inflow-hornetq quickstart. When executed on the server the rtgov does not record a business transaction. There is no exception in the log. I believe that's because getActivityCollector().endScope() is not called in AbstractExchangeEventProcessor.

The same behaviour is present when I call a SY service from CDI bean by injecting the @Reference to the SY service into CDI bean. It thus does not go through binding effectivelly bypassing endScope() call too.
Comment 1 Jiri Pechanec 2013-08-07 05:53:14 EDT
Hmm, in fact it seems it is related to the fact that the operation in question is one-way.
Comment 2 Gary Brown 2013-08-16 12:05:26 EDT
Verified this now works after fixing the one-way issue. Output from activity server REST query:

[
    {
        "type": "RequestReceived",
        "interface": "org.switchyard.quickstarts.jca.inflow.GreetingGateway",
        "operation": "english",
        "serviceType": "{urn:switchyard-quickstart:jca-inflow-hornetq:0.1.0}GreetingService",
        "messageType": "{urn:switchyard-quickstart:jca-inflow-hornetq:0.1.0}person",
        "context": [
            {
                "value": "ID-gbrown-redhat-55705-1376668804225-0-1",
                "type": "Message"
            }
        ],
        "unitId": "f063e84a-22d9-48fd-9f1e-9e2cde4dae3f",
        "timestamp": 1376668844366
    },
    {
        "type": "ResponseSent",
        "replyToId": "ID-gbrown-redhat-55705-1376668804225-0-1",
        "interface": "org.switchyard.quickstarts.jca.inflow.GreetingGateway",
        "operation": "english",
        "serviceType": "{urn:switchyard-quickstart:jca-inflow-hornetq:0.1.0}GreetingService",
        "context": [
            {
                "value": "ID-gbrown-redhat-55705-1376668804225-0-1onewayreturn",
                "type": "Message"
            }
        ],
        "unitIndex": 1,
        "unitId": "f063e84a-22d9-48fd-9f1e-9e2cde4dae3f",
        "timestamp": 1376668844472
    }
]
Comment 3 Jiri Pechanec 2013-09-16 06:57:37 EDT
Verified in ER2

Note You need to log in before you can comment on or make changes to this bug.