Bug 994431 - Win8-32 guest BSOD 0x1a after migration (with shadow paging)
Win8-32 guest BSOD 0x1a after migration (with shadow paging)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.0
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Marcelo Tosatti
Virtualization Bugs
:
Depends On:
Blocks: 1070247
  Show dependency treegraph
 
Reported: 2013-08-07 05:30 EDT by CongLi
Modified: 2014-06-18 02:09 EDT (History)
17 users (show)

See Also:
Fixed In Version: kernel-3.10.0-105.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1070247 (view as bug list)
Environment:
Last Closed: 2014-06-13 07:17:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BSOD screenshot (21.02 KB, image/jpeg)
2013-08-07 05:45 EDT, CongLi
no flags Details

  None (edit)
Description CongLi 2013-08-07 05:30:02 EDT
Description of problem:
Win8-32 guest BSOD 0x1a after migration 

Version-Release number of selected component (if applicable):
kernel-3.9.0-0.55.el7.x86_64
qemu-kvm-1.5.2-1.el7.x86_64
virtio-win-prewhql-0.1-65.iso

How reproducible:
50%

Steps to Reproduce:
1. Boot a guest with CML:
/home/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130807-160205-cFZ1shlI,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130807-160205-cFZ1shlI,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130807-160205-cFZ1shlI,path=/tmp/seabios-20130807-160205-cFZ1shlI,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130807-160205-cFZ1shlI,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-32-virtio.qcow2',index=0,if=none,id=drive-ide0-0-0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \
    -device virtio-net-pci,netdev=idIyGJ6V,mac='9a:53:54:55:56:57',bus=pci.0,addr=0x3,id='idxj3XC5' \
    -netdev tap,id=idIyGJ6V,vhost=on,fd=22 \
    -m 4096 \
    -smp 1,maxcpus=1,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G2',,+sep \
    -M pc \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',index=1,if=none,id=drive-ide0-0-1,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -enable-kvm

2. Login guest & do:
   w32tm /stripchart /samples:1 /computer:clock.redhat.com
   echo %errorlevel%

3. Do migration

4. Repeat step 2 & step 3 for 3 times.

Actual results:
Guest BSOD

Expected results:
Guest works well after migration

Additional info:
1. cpuinfo:
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 67
model name	: Dual-Core AMD Opteron(tm) Processor 1216
stepping	: 3
cpu MHz		: 1000.000
cache size	: 1024 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
bogomips	: 2009.13
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

2. mem_dump:
Microsoft (R) Windows Debugger Version 6.2.9200.20512 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\Administrator\Desktop\2013-08-07-16-11-33-Memory.dmp]
Kernel Bitmap Dump File: Only kernel address space is available

Symbol search path is: SRV*C:\symbols\*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 8 Kernel Version 9200 UP Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 9200.16384.x86fre.win8_rtm.120725-1247
Machine Name:
Kernel base = 0x8106c000 PsLoadedModuleList = 0x81256de8
Debug session time: Thu Aug  8 07:09:05.232 2013 (UTC + 8:00)
System Uptime: 0 days 0:03:13.290
Loading Kernel Symbols
...............................................................
................................................................
...
Loading User Symbols

Loading unloaded module list
.........
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1A, {3453, 87597340, 3344, 7}

Probably caused by : ntkrpamp.exe ( nt! ?? ::FNODOBFM::`string'+1b465 )

Followup: MachineOwner
---------

kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 00003453, The subtype of the bugcheck.
Arg2: 87597340
Arg3: 00003344
Arg4: 00000007

Debugging Details:
------------------


BUGCHECK_STR:  0x1a_3453

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from 811fa1f8 to 81163cb0

STACK_TEXT:  
829b8c34 811fa1f8 0000001a 00003453 87597340 nt!KeBugCheckEx
829b8c94 812a4c0d 87597340 00000000 84954440 nt! ?? ::FNODOBFM::`string'+0x1b465
829b8ca8 812a47af 849332e8 87597328 00000001 nt!MmDeleteProcessAddressSpace+0x29
829b8ce4 812aea2d 87597340 00000000 00000001 nt!PspProcessDelete+0x144
829b8cfc 813ae703 00000000 81243480 84954440 nt!ObpRemoveObjectRoutine+0x43
829b8d1c 810ed854 00000000 84954440 00000000 nt!ObpProcessRemoveObjectQueue+0x28
829b8d74 81130415 00000000 1dfee15b 00000000 nt!ExpWorkerThread+0x111
829b8db0 811dc039 810ed747 00000000 00000000 nt!PspSystemThreadStartup+0x4a
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt! ?? ::FNODOBFM::`string'+1b465
811fa1f8 84c2            test    dl,al

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt! ?? ::FNODOBFM::`string'+1b465

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrpamp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  5010adf0

BUCKET_ID_FUNC_OFFSET:  1b465

FAILURE_BUCKET_ID:  0x1a_3453_nt!_??_::FNODOBFM::_string_

BUCKET_ID:  0x1a_3453_nt!_??_::FNODOBFM::_string_

Followup: MachineOwner
---------
Comment 2 CongLi 2013-08-07 05:45:52 EDT
Created attachment 783778 [details]
BSOD screenshot
Comment 4 Yan Vugenfirer 2013-08-07 09:05:13 EDT
Hi,

Can you please uploaded ziped memory dump (preferably full or kernel memory dump)?

Thanks,
Yan.
Comment 11 Yan Vugenfirer 2014-01-14 07:46:20 EST
Hi,

Do you see this crash on RHEL6.5 as well?

Thanks,
Yan.
Comment 12 CongLi 2014-01-23 01:16:20 EST
(In reply to Yan Vugenfirer from comment #11)

Hi Yan,

I have tested it on RHEL.6.6 host many times, didn't hit this bug on the same machine. 

kernel-2.6.32-438.el6.x86_64
qemu-kvm-0.12.1.2-2.419.el6.x86_64

Thanks,
Cong
Comment 13 Marcelo Tosatti 2014-02-12 13:30:39 EST
CongLi,

The crash dump is not very helpful. Accordingly to
http://msdn.microsoft.com/en-us/library/windows/hardware/ff557391%28v=vs.85%29.aspx

0x00003453 is 



Please try the following:

1) Enable driver verifier. See instructions at http://msdn.microsoft.com/en-us/library/windows/hardware/ff545448%28v=vs.85%29.aspx#how_to_start_dv. Use the default settings.

If that fails to report new information, or if drivers now cause crashes even without migration, please report and continue to 2 below.

2) Confirm whether problem is reproducible with rtl8139 or e1000 and IDE disk.

If we can't isolate corruption a particular device, then it might be core migration data copy, and in that case could be related to bug which triggers

https://bugzilla.redhat.com/show_bug.cgi?id=1046870

Debugging 1046870 in the meantime.
Comment 14 Marcelo Tosatti 2014-02-12 13:36:25 EST
(In reply to Marcelo Tosatti from comment #13)
> CongLi,
> 
> The crash dump is not very helpful. Accordingly to
> http://msdn.microsoft.com/en-us/library/windows/hardware/ff557391%28v=vs.
> 85%29.aspx
> 
> 0x00003453 is 

"unknown memory management error".

It could be "PTEs of kernel thread are corrupt" AND 0x1, but lets try the tests listed in the previous comment.
Comment 16 CongLi 2014-02-20 03:26:40 EST
(In reply to Marcelo Tosatti from comment #13)

> Please try the following:
> 
> 1) Enable driver verifier. See instructions at
> http://msdn.microsoft.com/en-us/library/windows/hardware/ff545448%28v=vs.
> 85%29.aspx#how_to_start_dv. Use the default settings.
> 
> If that fails to report new information, or if drivers now cause crashes
> even without migration, please report and continue to 2 below.

Use the default settings, it prompts 'No unsigned drivers have been found'.
 
> 2) Confirm whether problem is reproducible with rtl8139 or e1000 and IDE
> disk.

Yes, it can be reproduced with rtl8139 or e1000 and IDE disk.

> If we can't isolate corruption a particular device, then it might be core
> migration data copy, and in that case could be related to bug which triggers
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1046870
> 
> Debugging 1046870 in the meantime.
Comment 17 CongLi 2014-02-20 04:36:45 EST
(In reply to CongLi from comment #16)

Tested on version:
kernel-3.10.0-89.el7.x86_64
qemu-kvm-rhev-1.5.3-49.el7.x86_64
Comment 18 Marcelo Tosatti 2014-02-21 16:41:25 EST
(In reply to CongLi from comment #17)
> (In reply to CongLi from comment #16)
> 
> Tested on version:
> kernel-3.10.0-89.el7.x86_64
> qemu-kvm-rhev-1.5.3-49.el7.x86_64

CongLi,

Can you provide full command line, for RTL8139/IDE case, and migration parameters
so that i can try to reproduce please?

Did you attempt to reproduce on Intel host?
Comment 19 Marcelo Tosatti 2014-02-21 17:50:52 EST
(In reply to CongLi from comment #16)
> (In reply to Marcelo Tosatti from comment #13)
> 
> > Please try the following:
> > 
> > 1) Enable driver verifier. See instructions at
> > http://msdn.microsoft.com/en-us/library/windows/hardware/ff545448%28v=vs.
> > 85%29.aspx#how_to_start_dv. Use the default settings.
> > 
> > If that fails to report new information, or if drivers now cause crashes
> > even without migration, please report and continue to 2 below.
> 
> Use the default settings, it prompts 'No unsigned drivers have been found'.
>  
> > 2) Confirm whether problem is reproducible with rtl8139 or e1000 and IDE
> > disk.
> 
> Yes, it can be reproduced with rtl8139 or e1000 and IDE disk.

Thats correct. Then you should be able to reboot the guest and driver verified should be enabled. Did you do that ?

I'll try to reproduce locally (once i have QEMU command line and migration command details), in the meantime.
Comment 20 Marcelo Tosatti 2014-02-23 15:04:26 EST
(In reply to Marcelo Tosatti from comment #18)
> (In reply to CongLi from comment #17)
> > (In reply to CongLi from comment #16)
> > 
> > Tested on version:
> > kernel-3.10.0-89.el7.x86_64
> > qemu-kvm-rhev-1.5.3-49.el7.x86_64
> 
> CongLi,
> 
> Can you provide full command line, for RTL8139/IDE case, and migration
> parameters
> so that i can try to reproduce please?
> 
> Did you attempt to reproduce on Intel host?

Or AMD hardware with NPT ?
Comment 21 CongLi 2014-02-24 01:13:15 EST
(In reply to Marcelo Tosatti from comment #18)

> Did you attempt to reproduce on Intel host?

No, have not met this issue on Intel host.

> Thats correct. Then you should be able to reboot the guest and driver verified should be enabled. Did you do that ?

Yes, I have reboot it, but there is nothing special when hit BSOD with verifier enabled. 

> Or AMD hardware with NPT ?

1. I met this bug on the AMD machine in comment 0 which has no NPT.
# cat /proc/cpuinfo | grep -i npt
# 

2. Haven't hit this problem on other AMD machine which has NPT.
processor	: 23
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 1
model name	: AMD Opteron(TM) Processor 6234                 
stepping	: 2
microcode	: 0x6000626
cpu MHz		: 2400.038
cache size	: 2048 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 75
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid amd_dcm aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext perfctr_core perfctr_nb arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
bogomips	: 4799.73
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb
Comment 22 CongLi 2014-02-24 01:34:44 EST
CML (rtl8139 & ide):

1. boot src guest:
/root/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga std  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140224-142410-xmzetVMD,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140224-142410-xmzetVMD,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20140224-142410-xmzetVMD,path=/tmp/seabios-20140224-142410-xmzetVMD,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20140224-142410-xmzetVMD,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-32.qcow2 \
    -device ide-hd,id=image1,drive=drive_image1,bus=ide.0,unit=0 \
    -device rtl8139,mac=9a:db:dc:dd:de:df,id=idQqJS0p,netdev=idVNvQ0L,bus=pci.0,addr=04  \
    -netdev tap,id=idVNvQ0L,fd=22  \
    -m 2048  \
    -smp 1,maxcpus=1,cores=1,threads=1,sockets=2  \
    -cpu 'Opteron_G2',+sep,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -no-hpet  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -rtc-td-hack \
    -enable-kvm \

2. query time in src vm:
w32tm /stripchart /samples:1 /computer:clock.redhat.com

3. boot dst vm:
same CML as src, except:
-vnc :1 \
-incoming tcp:0:5200 \

4. migrate src to dst in local host:
(qemu) migrate -d tcp:0:5200

5. do ping-pong migration 3 times w/ the above steps.
Comment 23 Marcelo Tosatti 2014-02-24 09:37:10 EST
(In reply to CongLi from comment #22)
> CML (rtl8139 & ide):
> 
> 1. boot src guest:
> /root/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
>     -S  \
>     -name 'virt-tests-vm1'  \
>     -sandbox off  \
>     -M pc  \
>     -nodefaults  \
>     -vga std  \
>     -chardev
> socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140224-142410-
> xmzetVMD,server,nowait \
>     -mon chardev=qmp_id_qmpmonitor1,mode=control  \
>     -chardev
> socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140224-142410-
> xmzetVMD,server,nowait \
>     -device isa-serial,chardev=serial_id_serial0  \
>     -chardev
> socket,id=seabioslog_id_20140224-142410-xmzetVMD,path=/tmp/seabios-20140224-
> 142410-xmzetVMD,server,nowait \
>     -device
> isa-debugcon,chardev=seabioslog_id_20140224-142410-xmzetVMD,iobase=0x402 \
>     -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
>     -drive
> id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/root/staf-
> kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-32.qcow2 \
>     -device ide-hd,id=image1,drive=drive_image1,bus=ide.0,unit=0 \
>     -device
> rtl8139,mac=9a:db:dc:dd:de:df,id=idQqJS0p,netdev=idVNvQ0L,bus=pci.0,addr=04 
> \
>     -netdev tap,id=idVNvQ0L,fd=22  \
>     -m 2048  \
>     -smp 1,maxcpus=1,cores=1,threads=1,sockets=2  \
>     -cpu
> 'Opteron_G2',+sep,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic \
>     -drive
> id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/root/staf-kvm-
> devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso
> \
>     -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=1 \
>     -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
>     -vnc :0  \
>     -no-hpet  \
>     -rtc base=localtime,clock=host,driftfix=slew  \
>     -boot order=cdn,once=c,menu=off  \
>     -rtc-td-hack \
>     -enable-kvm \
> 
> 2. query time in src vm:
> w32tm /stripchart /samples:1 /computer:clock.redhat.com
> 
> 3. boot dst vm:
> same CML as src, except:
> -vnc :1 \
> -incoming tcp:0:5200 \
> 
> 4. migrate src to dst in local host:
> (qemu) migrate -d tcp:0:5200
> 
> 5. do ping-pong migration 3 times w/ the above steps.

Thanks CongLi. 

While i setup the environment, can you confirm its reproducible on Intel 
with kvm_intel module parameter ept=0 ?
Comment 24 CongLi 2014-02-24 22:35:44 EST
(In reply to Marcelo Tosatti from comment #23)

> While i setup the environment, can you confirm its reproducible on Intel 
> with kvm_intel module parameter ept=0 ?

Yes, it can be reproduced on Intel host with kvm_intel module parameter ept=0.

# modprobe kvm_intel "ept=0"

cpuinfo:
processor	: 23
vendor_id	: GenuineIntel
cpu family	: 6
model		: 45
model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
stepping	: 7
microcode	: 0x710
cpu MHz		: 2318.203
cache size	: 15360 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 43
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4004.09
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

Thanks,
Cong
Comment 27 Jarod Wilson 2014-02-28 11:58:56 EST
A kernel patch was submitted against this bug, so this bug needs to be against the kernel component. You'll have to reacquire flags now, unfortunately.
Comment 28 Jarod Wilson 2014-03-05 13:42:09 EST
Patch(es) available on kernel-3.10.0-105.el7
Comment 31 huiqingding 2014-03-10 01:46:52 EDT
When I verify this bug, hit this BZ 1036478: after win8 32 bits guest migraion, the DST no response from UI, but the mouse can move, and can ping guest from host.

The kernel and qemu-kvm version is:
kernel-3.10.0-107.el7.x86_64
qemu-kvm-1.5.3-52.el7.x86_64

Steps ot Reproduce 
1. boot guest on src and dst host: 
src: 
# /usr/libexec/qemu-kvm -M pc -cpu SandyBridge -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1 -name win8-32 -uuid 6afa5f93-2d4f-420f-81c6-e5fdddbd1c83 -drive file=/home/win8-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:42:0a:00,bus=pci.0,addr=0x3 -vnc :2  -monitor stdio  -qmp tcp:0:4445,server,nowait

dst: 
# /usr/libexec/qemu-kvm -M pc -cpu SandyBridge -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1 -name win8-32 -uuid 6afa5f93-2d4f-420f-81c6-e5fdddbd1c83 -drive file=/home/win8-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:42:0a:00,bus=pci.0,addr=0x3 -vnc :3  -monitor stdio  -qmp tcp:0:4446,server,nowait -incoming tcp:0:5200

2. do three rounds migration
(qemu) migration -d tcp:0:5200

Actual results:
after win8 32 bits guest migraion, the DST no response from UI, but the mouse can move, and can ping guest from host.
Comment 32 juzhang 2014-03-17 21:58:42 EDT
QE would like to set this as verified and continue to track BZ 1036478.

When qe verify BZ 1036478, qe will have a try this scenarios as well.
Comment 33 Ludek Smid 2014-06-13 07:17:54 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.