Bug 994473 - desktop icons reappear in “gnome classic” when they are switched off with gnome-tweak-tool or dconf
desktop icons reappear in “gnome classic” when they are switched off with gno...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 07:06 EDT by Mike FABIAN
Modified: 2014-11-20 11:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-15 11:35:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
desktop-icons-reappear.ogv (1.72 MB, video/ogg)
2013-08-07 07:06 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-08-07 07:06:48 EDT
Created attachment 783809 [details]
desktop-icons-reappear.ogv

- Log in to "gnome classic" in Fedora 19.
- Switch off desktop icons using:

  dconf write /org/gnome/desktop/background/show-desktop-icons false

- Wait 30 seconds

→ The desktop icons appear again

See attached video.
Comment 1 Mike FABIAN 2013-08-07 07:08:06 EDT
Related to bug#965383 ?

https://bugzilla.redhat.com/show_bug.cgi?id=965383#c3
Comment 2 Florian Müllner 2013-08-07 10:35:44 EDT
gnome-shell is not involved in drawing desktop icons, but the file manager. Are you using nemo as implied by the referenced bug? Nautilus?
Comment 3 Mike FABIAN 2013-08-10 08:30:43 EDT
(In reply to Florian Müllner from comment #2)
> gnome-shell is not involved in drawing desktop icons, but the file manager.
> Are you using nemo as implied by the referenced bug? Nautilus?

It is a default installation of Fedora 19.

There seems to be nothing called nemo:

[mfabian@Fedora-19-RC3-x86_64-netinst ~]$ rpm -qa | grep -i nemo
[mfabian@Fedora-19-RC3-x86_64-netinst ~]$ ps aux | grep -i nemo
mfabian  12110  0.0  0.0 112660   896 pts/1    S+   16:30   0:00 grep --color=auto -i nemo
[mfabian@Fedora-19-RC3-x86_64-netinst ~]$
Comment 4 Mike FABIAN 2013-08-10 08:33:14 EDT
[mfabian@Fedora-19-RC3-x86_64-netinst ~]$ ps aux | grep -i nautilus
mfabian   7575  0.0  1.2 941708 24704 ?        Sl    8月07   0:00 nautilus --no-default-window --force-desktop
mfabian  12113  0.0  0.0 112660   900 pts/1    S+   16:31   0:00 grep --color=auto -i nautilus
[mfabian@Fedora-19-RC3-x86_64-netinst ~]$ 

$ LANG=en_GB.UTF-8 nautilus --help | grep desktop
  --no-desktop                Never manage the desktop (ignore the GSettings preference).
  --force-desktop             Always manage the desktop (ignore the GSettings preference).

So this “--force-desktop” option probably causes the problem.
Comment 5 Matthew Garrett 2013-08-24 11:44:45 EDT
The argument is coming from nautilus-classic.desktop.
Comment 6 Mike FABIAN 2013-10-15 16:17:06 EDT
The problem still exists in Fedora 20 Beta TC4.
Comment 7 Matthias Clasen 2014-11-15 11:35:48 EST
I don't consider this a bug. Desktop icons are a fixed part of the gnome-classic setup. We introduced the --force-desktop option specifically to be independent of the setting.
Comment 8 Florian Müllner 2014-11-20 08:41:24 EST
(In reply to Matthias Clasen from comment #7)
> I don't consider this a bug. Desktop icons are a fixed part of the
> gnome-classic setup.

With this in mind, gnome-tweak-tool should probably not show the corresponding option in classic mode.
Comment 9 Mike FABIAN 2014-11-20 11:22:00 EST
Yes, it is weird if the icons disappear and suddenly appear again later.
Not showing the option in gnome-tweak-tool would be less confusing.

Note You need to log in before you can comment on or make changes to this bug.