Bug 994528 - Add user documentation for the new cache store(s) available in JDG 6.2.
Add user documentation for the new cache store(s) available in JDG 6.2.
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 6.2.0
Assigned To: Mandar Joshi
Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 08:57 EDT by Mircea Markus
Modified: 2015-08-31 22:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 19:01:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mircea Markus 2013-08-07 08:57:38 EDT
Document URL: 

Section Number and Name: 

Describe the issue: 

Add user documentation for the new SingleFilceCacheLoader implementation available in JDG 6.2. We'll also provide a migration tool from the existing FileCacheStore to the new one. This migration tool should be documented as well.

The new file cache store will be added to JDG 6.2 as part of a change request: https://docspace.corp.redhat.com/docs/DOC-149662

It is not certain at this time if the change request will include another cache store as well, the LevelDB cache store. If the LevelDB cache store will be added as well, it will require documentation.

Documentation references:

SingleFileCacheStore:
- https://docs.jboss.org/author/display/ISPN/Cache+Loaders+and+Stores
- http://infinispan.blogspot.co.uk/2013/07/faster-file-cache-store-no-extra.html
- Galder Zamarreño (galder@redhat.com) can provide more detailed information on this cache store if needed

LevelDB:
- https://docs.jboss.org/author/display/ISPN/Cache+Loaders+and+Stores
- http://infinispan.blogspot.co.uk/2013/06/introducing-leveldb-cache-store.html
- Ray Tsang (rtsang@redhat.com) can provide more detailed information on this cache store if needed

Migration tool:
- hasn't been implemented nor documented yet
- Galder Zamarreño (galder@redhat.com) to implement it as part of https://issues.jboss.org/browse/ISPN-3318
Suggestions for improvement: 

Additional information:
Comment 3 Misha H. Ali 2013-08-15 02:37:59 EDT
Update, only SingleCacheFileStore documentation required for this bug now. IIUC:

1. LevelDB cache store documented as part of https://bugzilla.redhat.com/show_bug.cgi?id=974321

2. The Migration tool is unscoped and may or may not be available. 

Assigning this bug to Mandar for above since he documented the LevelDB cache store.
Comment 12 Misha H. Ali 2013-11-27 06:18:54 EST
I got a bug to fix the config for this:

https://bugzilla.redhat.com/show_bug.cgi?id=1028796

So the config should be OK. Please confirm with Vitalii that this is now OK (he is reviewing my bug shortly).
Comment 14 Misha H. Ali 2013-12-02 18:37:36 EST
Who needs to review this? Add Need info please.
Comment 16 Martin Gencur 2013-12-04 05:10:42 EST
Assigning this to Jakub.
Comment 18 Jakub Markos 2013-12-10 09:06:21 EST
Also the migration section is pretty brief, maybe we might want to talk a bit more about the process?
Comment 25 Misha H. Ali 2014-01-15 19:01:34 EST
The fix for this bug is now generally released and available here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.2/index.html

Note You need to log in before you can comment on or make changes to this bug.