Bug 994548 - Problems with packaging of python27 depending collections
Problems with packaging of python27 depending collections
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: python (Show other bugs)
python27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Bohuslav "Slavek" Kabrda
Branislav Náter
:
Depends On:
Blocks: 969038 1019238
  Show dependency treegraph
 
Reported: 2013-08-07 09:37 EDT by Bohuslav "Slavek" Kabrda
Modified: 2014-06-04 03:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: python27-python-2.7.5-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994570 1019238 1372701 (view as bug list)
Environment:
Last Closed: 2014-06-04 03:26:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bohuslav "Slavek" Kabrda 2013-08-07 09:37:37 EDT
There are some problems when packaging collections depending on python27:
1) %__python macro is defined in form of %{__bindir}/python, which makes the macro point somewhere else (%__bindir is /opt/rh/<new_collection>)
2) %python27_os_install_post has "scl enable %{scl}", which doesn't enable python27 collection and python fails (can't find correct libpython.so)

1) should be solved by creating %python27_python macro (with hardcoded path) and using it in collection metapackage in %scl_package_override to redefine %__python
2) should be solved by hardcoding "python27" as scl name to make sure it is always invoked properly
Comment 1 Bohuslav "Slavek" Kabrda 2013-08-07 09:52:48 EDT
Also, %python_{sitelib,sitearch,version} should be handled similarly as %__python.
Comment 7 errata-xmlrpc 2014-06-04 03:26:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0610.html

Note You need to log in before you can comment on or make changes to this bug.