Bug 99463 - dialup interacts badly with nscd
Summary: dialup interacts badly with nscd
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-20 15:02 UTC by Nils O. Selåsdal
Modified: 2016-11-24 14:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 19:30:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils O. Selåsdal 2003-07-20 15:02:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I'm running nscd since I'm on an "ldap based" network, sometimes I need to
dialup other networks, using redhat-control-network to dial. now, ppp needs, and
gets dns servers for this dialup session, however when nscd is running it
doesn't always pick up that /etc/resolv.conf changed. Sometimes it does,
sometimes it does not.
It always should imho.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Run nscd to cache userinfo/hostnames etc.
2. dial up to another host so /etc/resolv.conf changes.
3. resolving hosts should now instantly use the new dns servers in /etc/resolv.conf
    

Actual Results:  It doesn't always pick up the changed /etc/resolv.conf

Expected Results:  It should pick up the changed /etc/resolv.conf

Additional info:

Workaround is to manually restart nscd

Comment 1 Harald Hoyer 2003-07-21 10:19:02 UTC
reassigning to nscd...

Comment 2 Jakub Jelinek 2003-07-22 11:48:28 UTC
It should be the task of whatever script modifies resolv.conf to service nscd condrestart
IMHO.

Comment 3 Jakub Jelinek 2004-10-03 19:30:42 UTC
Things changed, now nscd -i hosts is the recommended way to ask nscd
to reread resolv.conf.


Note You need to log in before you can comment on or make changes to this bug.