Bug 99464 - dialup interacts badly with dhcp
dialup interacts badly with dhcp
Status: CLOSED DUPLICATE of bug 130437
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-07-20 11:11 EDT by Nils O. Selåsdal
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:57:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nils O. Selåsdal 2003-07-20 11:11:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Our hosts are configured with dhcp, and a rather low lease time(1 hour) due to
using ddns I'm told. Sometimes I need to dial up other hosts/networks using
redhat-control-network. Other than this bug and #99463 I also just entered this
is fine, until the lease expires I guess. Then in the middle of a ppp session
/etc/resolv.conf gets updated with info from our own dhcp server, overwriting
the info from the ppp session.

Version-Release number of selected component (if applicable):
The one that comes with RH9(+ erratas)

How reproducible:

Steps to Reproduce:
1. Configure host with dhcp
2. dial up another host(ppp)
3. wait for dhcp lease to expire

Actual Results:  /etc/resolv.conf from the ppp session gets overwritten by the
dhcp client.

Expected Results:  /etc/resolv.conf (and possibly other things ?) should be
valid for the lifetime of the dialup session. Well, one should berhaps be given
the option of which settings are preferred over another when having 2 or more
active profiles in redhat-config/control-network

Additional info:
Comment 1 Harald Hoyer 2003-07-21 06:28:40 EDT
actually there is no parameter which specifies the preferences on updating
Comment 2 Daniel Walsh 2003-11-06 10:01:47 EST
Harald how do you want me to handle this?  I don;t know how the
alternate profiles work.
Comment 3 Jason Vas Dias 2004-08-30 18:43:04 EDT
With dhcp-3.0.1-+,
the preferred nameservers and search domain can be specified
in /etc/dhclient.conf as:
'prepend domain-name <my preferred search list>
 prepend domain-name-servers <my preferred domain name servers>',
which will overide the settings obtained from a remote dhcp server
with local preferences.
Comment 4 Jason Vas Dias 2005-06-03 14:52:17 EDT

*** This bug has been marked as a duplicate of 130437 ***
Comment 5 Jason Vas Dias 2005-06-03 14:57:56 EDT
The network configuration GUI tool should provide some means of configuring
the resolv.conf parameter preferences by interface using dhclient.conf .
I'll volunteer to develop a "dhclient configuration module" for 
system-config-network if desired.
Comment 6 Red Hat Bugzilla 2006-02-21 13:57:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.