Bug 994668 - missing time man page
missing time man page
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: man-pages (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 14:13 EDT by gilgamesh2k
Modified: 2013-08-14 12:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 12:09:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gilgamesh2k 2013-08-07 14:13:29 EDT
Description of problem:
gilga@localhost ~$ man time
Manuálová stránka pro time nebyla nalezena


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Peter Schiffer 2013-08-14 08:51:30 EDT
Try to install man pages packages:

# yum install man-pages man-pages-cs

peter
Comment 2 gilgamesh2k 2013-08-14 09:25:40 EDT
Works.
But may I ask - how is it that a lot of commands have their man page installed and time doesn't? Isn't it considered to be part of the standard command set?
Thanks for the solution anyway :-)
Comment 3 Peter Schiffer 2013-08-14 09:35:51 EDT
Did you do standard installation from live CD? (And, assuming, did you choose Czech language during the installation?)

peter
Comment 4 gilgamesh2k 2013-08-14 09:40:27 EDT
Yes, standard installation from F19 Live CD.
Ehm, not sure about the installation language. But afterwards I'm definitely using czech gui in all software installed. Also I do have most man pages in czech.
Comment 5 Peter Schiffer 2013-08-14 12:09:15 EDT
OK, I've checked: man-pages package is not installed by default in Fedora - I'm assuming this is because it's size, as we want the installation media to be as small as possible.

Man-pages package contains mostly man pages documenting system calls, libraries, etc.. and few extra man pages for programs like time or ldd. Rest of the programs have man pages bundled within their packages, so if you install vim, you also get the vim(1) man page.

Also, time command is a little bit special. There are 2 types of this command: one is bash(1) built-in command and the second one is /usr/bin/time. The time(1) man page is for the latter, but when you run only "time", the bash built-in is executed.

peter
Comment 6 gilgamesh2k 2013-08-14 12:21:08 EDT
So some man pages (grep, which, locate) are installed, some are not.
And that is because of the size of the installation media (perhaps).
Altough I don't understand what is the key to be included among the standard commands set (I mean commands that have man pages after installation), thank you for the yum install sequence :-)
Comment 7 Ondrej Vasik 2013-08-14 12:28:24 EDT
Some utilities/projects provide man pages in their rpms (in fact most of the programs). Some are not, as they were traditionally included in man-pages project - and you need man-pages package if you want them. E.g. all syscall man pages are in man-pages package (see rpm -ql man-pages | grep man2 if you already have man-pages package installed).
In addition - in some cases, man-pages package contains POSIX version of the manpage and package itself contains the project man page (like in the case of many core utilities - like cp - man 1p cp and man cp differs).
Comment 8 gilgamesh2k 2013-08-14 12:36:18 EDT
Thank you for your explanation.

Note You need to log in before you can comment on or make changes to this bug.