Bug 99467 - (ACPI) Acpi support in kernel 2.4.XX series crash reading DSDT table
(ACPI) Acpi support in kernel 2.4.XX series crash reading DSDT table
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: acpi (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
http://abaababa.ouvaton.org/presario
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-20 14:02 EDT by Sabax
Modified: 2013-07-02 22:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:39:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
acpidmp and dmesg united in an unique file (126.76 KB, text/plain)
2003-08-26 08:43 EDT, Sabax
no flags Details
fixed DSDT (177.33 KB, text/plain)
2003-09-08 04:49 EDT, shaohua li
no flags Details
created file with error message (28.18 KB, text/plain)
2003-09-14 07:13 EDT, Sabax
no flags Details
fixed DSDT (212.39 KB, text/plain)
2003-09-15 04:38 EDT, shaohua li
no flags Details
line text on boot and iasl eoors on compiling (3.04 KB, text/plain)
2003-09-17 17:27 EDT, Sabax
no flags Details

  None (edit)
Description Sabax 2003-07-20 14:02:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Presario 1700 and 2100 have notorious problems with acpi control, that seem to 
be partially obscured by Hp(compaq was acquired by Hp). I have a presario 
2154ea and i had problems with DSDT table, due to enable acpi.i resorved 
partially problems with a patch for initrd.img i found at 
http://abaababa.ouvaton.org/presario, but is only partially. I would be 
grateful if you put on blacklist presario 2100 series or resolve problems

Version-Release number of selected component (if applicable):
linux kernel 2.4.21 - > 2.4.21-bk15

How reproducible:
Always

Steps to Reproduce:
1.Install linux-2.4.21
2.enable acpi complete with debug ,with or without patch updated by kernel.org
3.bzImage,make modules, make modules_install,put bzImge as vmlinuz, system.map 
as system.map-xx.xx.xx, mkinitrd initrd-xx.xx.xx.img in /boot and make bootable 
in lilo

Actual Results:  notebook hang at reading dsdt table

Expected Results:  hang on booting acpi

Additional info:

it seems a problem of a bogus velue returned by DSDT table and others that 
return infinite values. for additional information i refered to site 
http://abaababa.ouvaton.org/presario
Comment 1 Luming Yu 2003-08-26 05:54:01 EDT
Please attach acpidmp and dmesg 
Comment 2 Sabax 2003-08-26 08:43:55 EDT
Created attachment 93932 [details]
acpidmp and dmesg united in an unique file
Comment 3 Sabax 2003-08-26 13:18:57 EDT
i have attached and sent the acpidmp and dmesg here and not as files ^.^ . I'm
very pleased that my problem is considerated. If this can help you, i'm using
2.4.21-bk24 patched dsdt table with the files avaible in the site i specified.
kernel 2.4.22 final version, works only with this patch, as 2.4.21, and generate
the same error at the same line as 2.4.21. 
Comment 4 shaohua li 2003-09-08 04:49:00 EDT
Created attachment 94289 [details]
fixed DSDT

would you like to test the fixed DSDT, though it's partially fixed.
Comment 5 Sabax 2003-09-08 06:22:57 EDT
excuse me, but how can i use the file of dsdt patched that u've attached? 
thanks for your patience.
Comment 6 Sabax 2003-09-14 07:13:16 EDT
Created attachment 94482 [details]
created file with error message

Hi. i've tried the patch various times, also reinstalling rh9 and recompiling
kernel, using iasl released 23 may 2003, but every times it give me an error in
compiling(for exact 200 errors, and at 201° error iasl stop. 
i think the error is due to a value not recognized by it: (0x0D). 
it must be depending my computer? note that at this moment i'm not using the
dsdt patch of the site where i discover the DSDT bogus. 
i'm in error for the procedure? i've forgot something?
i have saved the attachment as fixed.dsl and i compiled with the command:
./iasl -tc fixed.dsl .
Otherwise, do you think a precompiled aml can resolve the situation? 
here i'v attached the file with the execution of iasl. i am at your
disposition,for every need. 
very thanks Luca Sabatini
Comment 7 shaohua li 2003-09-15 04:38:50 EDT
Created attachment 94488 [details]
fixed DSDT

pl. try this DSDT
Comment 8 Sabax 2003-09-16 13:58:04 EDT
I compiled DSDT.hex into kernel and it had work on creating bzImage and 
modules, At boot, now don't Hang on the line: PCI: Using configuration type 
1,but add a line before hang: 

ACPI-0292: *** Info: Table [DSDT] replaced by Host OS

I tried to boot with option pci_=_noacpi, but is the same result. It seems a 
good result, but not definitive.

Thanks for your work. i'll wait for every need.
Luca Sabatini
Comment 9 Sabax 2003-09-16 14:51:47 EDT
News: i tried to debug your attachment named 99467_dsl with iasl -d , and it 
result is: 

Loading Acpi Table from file dsdt
tbutils-0221: *** warning: invalid table signature found: [/*]
Table header is invalid!
Couldn't get table from file

Could this be the error that don't allow dsdt to be compiled/working?
I hope this can halp you.
Luca Sabatini
Comment 10 Sabax 2003-09-17 17:27:52 EDT
Created attachment 94567 [details]
line text on boot and iasl eoors on compiling

here i attach a file in which i explain how i do resolve the problem
ofcompiling and describe the text and messages that appear me when i compile
iasl and when i reboot
Comment 11 Jeff Garzik 2004-03-03 03:39:00 EST
RHL9 didn't ship with ACPI enabled, closing.

Please test latest Fedora Core with acpi=on if you wish to help debug
ACPI further (and open a new bug, if you find a bug there).

Note You need to log in before you can comment on or make changes to this bug.