Bug 99479 - mixed white space entries not matched in NIS maps
mixed white space entries not matched in NIS maps
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-20 22:47 EDT by Ian Mortimer
Modified: 2015-01-07 19:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2003-07-20 22:47:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
After the errata upgrade on our NIS server some automount map entries were no
longer being matched.  They showed up in `ypcat -k auto.home' but not in
`ypmatch user auto.home'.

All the entries that failed had a space followed by one or more tabs between the
two fields of the map.  All other entries had either all spaces or all tabs.

Changing the failing entries to all spaces or all tabs fixed the problem.

Version-Release number of selected component (if applicable):
ypserv-2.8-0.73E

How reproducible:
Always

Steps to Reproduce:
1. Create a NIS map with two fields separated by white space
2. For some entries separate the fields with a space followed by one or more tabs
3. do 'ypmatch name map_name' for the mixed white space entries
    

Actual Results:  ypmatch returns:

   Can't match key _user_ in map _map_. Reason: No such key in map

Expected Results:  ypmatch should have shown the entry since ypcat -k _map_
showed it.
This worked fine prior to the errata upgrade.

Additional info:

This is not serious since it's easily worked aroubd but in an environment like
ours where NIS maps have been imported from other OSes and maintained by several
generations of admins it might not be easy to see what the problem is.  It was
only after looking at the maps using vi in :list mode that I was able to see it.
 Otherwise the misbehaving entries looked identical to the good ones.
Comment 1 Konstantin Olchanski 2003-08-25 18:34:18 EDT
This problem is not benign. Existing and obviously correct NIS maps unexpectedly
stopped working and it was very hard to trace the problem down to particular
combinations of spaces and tabs in /etc files. Most text editors do not visually
distinguish between spaces and tabs, and, even worse, arbitrary convert tabs
into spaces and spaces into tabs. K.O.
Comment 2 Steve Dickson 2004-10-15 08:27:56 EDT
fixed in ypserv-2.8-0.9E
Comment 3 Bill Nottingham 2006-08-04 16:06:03 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.