Bug 994819 - RFE: Add information about commit message for the csprocessor
RFE: Add information about commit message for the csprocessor
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Documentation (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
lcarlon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 00:53 EDT by Lee Newson
Modified: 2015-05-06 02:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-06 02:14:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-08-08 00:53:54 EDT
Currently there isn't any information in the PressGang CCMS Handbook about how to add commit messages when using the csprocessor.

To do this you need to add "--message <MESSAGE>" or "-m <MESSAGE" to the push, create or snapshot commands. If you add the "--rev-history" parameter as well it'll mark the commit message as an important commit that should have its message added into an auto generated Revision_History.xml file (see BZ#861277)

Examples:

csprocessor push my_local_file.contentspec -m "Fix for BZ#123456"

or

csprocessor push my_local_file.contentspec -m "Fix for BZ#123456" --rev-history

Extra Information:

When adding a commit message the username that is stored in csprocessor.ini or specified via the command line (by doing --username lnewson), is the username the commit will be attributed to.
Comment 1 Jared MORGAN 2013-12-16 19:49:55 EST
I've added this content to Topic 14083.

Push Changes, and Add a Commit Message
Push Changes, and Add a Commit Message to the Revision_History Content

I deleted some of the content in these two new varlistentry items from the "Push Changes to a Map" because the content was getting too long.

It might be worthwhile restructuring this section into separate task topics so they are a bit more discoverable in the TOC. I might do that another time.
Comment 3 Lee Newson 2015-05-06 02:14:41 EDT
Verified

Note You need to log in before you can comment on or make changes to this bug.