Bug 994892 - Time where a task was claimed is not logged
Time where a task was claimed is not logged
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.0.0
Assigned To: Kris Verlaenen
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 04:28 EDT by Jan Hrcek
Modified: 2014-08-06 16:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:01:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the feature (61.98 KB, image/png)
2014-02-18 03:04 EST, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-08-08 04:28:46 EDT
Description of problem:
In the PRD for BPMS 6.0 there is requirement PET-18 - "RFE: Log the time that task is accepted" (based on https://issues.jboss.org/browse/PRODMGT-306).

However, I was unable to find this functionality in JBPM. There is no method to get this info in org.kie.api.task.model.TaskData, nor was I able find a field in the database where this info is stored.
Comment 1 Kris Verlaenen 2013-08-08 14:10:26 EDT
This was implemented before for 5.3.x (see https://github.com/droolsjbpm/jbpm/commit/1e5be437671657cc351afcdb8190f017208953a4).

However, 6.0 provides a more complete logging of task events using BAMTaskEventListener.

Mauricio, is this enabled by default?  If so, could you clarify where to look, if not, could you specify how to enable it as well?
Comment 2 Mauricio Salatino 2013-09-26 17:03:30 EDT
Basically we were logging some information to send to the dashboard application, but we didn't have any service that we can use internally in the jbpm console side. I've implemented this service and I added a log section in the Task Details screen.

Fixed in master: http://github.com/droolsjbpm/jbpm-console-ng/commit/4f3232a6c
Comment 3 Jan Hrcek 2013-10-23 08:31:16 EDT
The feature is still missing in the UI. I checked with the decompiler and the fixing commit is not present in the BPMS 6.0.0 ER4.

Please include it so we can test it in ER5.
Comment 7 Jan Hrcek 2014-02-18 03:03:26 EST
I believe this is implemented and seems to be already working in BPMS 6.0.1 ER1 - In Task List > Details panel, there is Log section, that displays all the task events (see screenshot). If engineering agrees, please move this BZ to MODIFIED or directly to ON_QA, so we can verify this.
Comment 8 Jan Hrcek 2014-02-18 03:04:52 EST
Created attachment 864411 [details]
Screenshot showing the feature
Comment 9 Jan Hrcek 2014-02-18 03:37:59 EST
After confirmation from engineering moving to ON_QA for verification. There is a small issue about username not being loged for Taks RELEASED event, but that will be reported in another bugzilla.
Comment 10 Jan Hrcek 2014-02-19 03:57:54 EST
Ok, verified in BPMS 6.0.1 ER1

Note You need to log in before you can comment on or make changes to this bug.