Bug 994898 - redhat-support-plugin-rhev - triggerscriptlet issue: No such file or directory
redhat-support-plugin-rhev - triggerscriptlet issue: No such file or directory
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Spenser Shumaker
Spenser Shumaker
external
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 04:39 EDT by Jiri Belka
Modified: 2016-02-10 13:58 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 04:12:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: External
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from console with line numbers (1.80 MB, text/plain)
2013-08-08 04:39 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-08-08 04:39:39 EDT
Created attachment 784253 [details]
output from console with line numbers

Description of problem:
trigger scriptlets defined in redhat-support-plugin-rhev tries to make some modifications if rhevm package is installed but this modification is done in paths which are not yet present.

one can face this issue if redhat-support-plugin-rhev gets installed before rhevm-backend...

...
  Installing : rhevm-setup-3.3.0-0.14.master.el6ev.noarch                                                                                                                                21/24 
  Installing : redhat-support-plugin-rhev-3.3.0-2.el6ev.noarch                                                                                                                           22/24 
  Installing : rhevm-3.3.0-0.14.master.el6ev.noarch                                                                                                                                      23/24 
grep: /usr/share/ovirt-engine/engine.ear/META-INF/application.xml: No such file or directory
sed: can't read /usr/share/ovirt-engine/engine.ear/META-INF/application.xml: No such file or directory
  Installing : rhevm-backend-3.3.0-0.14.master.el6ev.noarch                                                                                                                              24/24 
  Verifying  : rhevm-backend-3.3.0-0.14.master.el6ev.noarch                                                                                                   
...

in details:

...
 11040  D:   install: %post(rhevm-3.3.0-0.14.master.el6ev.noarch) scriptlet start
 11041  D:   install: %post(rhevm-3.3.0-0.14.master.el6ev.noarch)       execv(/bin/sh) pid 7706
 11042  D:   install: waitpid(7706) rc 7706 status 0 secs 0.009
 11043  D:   install: %triggerin(rhevm-3.3.0-0.14.master.el6ev.noarch) scriptlet start
 11044  D:   install: %triggerin(rhevm-3.3.0-0.14.master.el6ev.noarch)  execv(/bin/sh) pid 7707
 11045  + grep -q '<web-uri>redhat-support-plugin-rhev.war</web-uri>' /usr/share/ovirt-engine/engine.ear/META-INF/application.xml
 11046  grep: /usr/share/ovirt-engine/engine.ear/META-INF/application.xml: No such file or directory
 11047  + sed -i '/<\/application>/i \
 11048          <!-- START Red Hat Support Plug-in DO NOT REMOVE THIS COMMENT --> \
 11049          <module> \
 11050          <web> \
 11051          <web-uri>redhat-support-plugin-rhev.war<\/web-uri> \
 11052          <context-root>\/redhat-support-plugin-rhev<\/context-root> \
 11053          <\/web> \
 11054          <\/module> \
 11055          <!-- END Red Hat Support Plug-in DO NOT REMOVE THIS COMMENT -->' /usr/share/ovirt-engine/engine.ear/META-INF/application.xml
 11056  sed: can't read /usr/share/ovirt-engine/engine.ear/META-INF/application.xml: No such file or directory
 11057  + '[' -d /var/lib/ovirt-engine/deployments ']'
 11058  D:   install: waitpid(7707) rc 7707 status 0 secs 0.018
...

triggerin is part of redhat-support-plugin-rhev (check rpm --triggers -q redhat-support-plugin-rhev) and is registered in /var/lib/rpm/Triggername. when rhevm is installed this trigger is executed but the path is part of rhevm-backend which is installed right after rhevm...

# rpm -qf /usr/share/ovirt-engine/engine.ear
rhevm-backend-3.3.0-0.14.master.el6ev.noarch

quick checking of rpm docs seems triggered package (target) does not seem to be needed as dependency of the package registering triggers. i want to say, changing triggered package in redhat-support-plugin-rhev specfile to 'rhevm-backend' could be sufficient... (but i'm not specialist in this topic).

Version-Release number of selected component (if applicable):
is9

How reproducible:
100%

Steps to Reproduce:
1. yum remove \*rhev\* \*otopi\* \*vdsm\* \*redhat-support\*
2. yum install redhat-support-plugin-rhev
3. 

Actual results:
trigger scriptlets issue - No such file or directory

Expected results:
no bogus during installation

Additional info:
Comment 3 Charlie 2013-11-27 20:34:17 EST
This bug is currently attached to errata RHBA-2013:15513. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 4 Charlie 2013-12-05 19:19:05 EST
Hi, was this issued resolved and does it need doc text?
Comment 5 Spenser Shumaker 2013-12-09 10:21:51 EST
This should not need doc.

Note You need to log in before you can comment on or make changes to this bug.