Bug 994989 - when service nfs start fail, should output useful error info to user.
when service nfs start fail, should output useful error info to user.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.0
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
: Reopened
Depends On:
Blocks: 1002484
  Show dependency treegraph
 
Reported: 2013-08-08 07:03 EDT by Yin.JianHong
Modified: 2013-08-29 07:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1002484 (view as bug list)
Environment:
Last Closed: 2013-08-29 05:59:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-08-08 07:03:28 EDT
Description of problem:
when service nfs start  fail, should output useful error info to user.
more than "Job for nfs-server.service failed. See 'systemctl status nfs-server.service' and 'journalctl -xn' for details."

Version-Release number of selected component (if applicable):
RedHatEnterpriseWorkstation 7.0
Linux dhcp12-125.nay.redhat.com 3.10.0-0.rc7.64.el7.x86_64 #1 SMP Tue Jun 25 10:00:04 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux
nfs-utils-1.2.8-2.0.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  echo 'RPCNFSDARGS="--no-tcp"' >/etc/sysconfig/nfs
    service nfs start
2.
3.

Actual results:
Job for nfs-server.service failed. See 'systemctl status nfs-server.service' and 'journalctl -xn' for details.

Expected results:
---->
Job for nfs-server.service failed. See 'systemctl status nfs-server.service' and 'journalctl -xn' for details.
+rpc.nfsd: version 4 requires the TCP protocol
<----
Additional info:
  police: Stop, Your application does not meet the requirements
          Specific reason please ask my colleagues 'journalctl' in next room
  people: ??? Why you do not tell me???
Comment 5 Yin.JianHong 2013-08-29 06:01:59 EDT
I means that  it should give user the reason directly in the stderr. 
-like in RHEL6 and RHEL5
Comment 6 Steve Dickson 2013-08-29 06:13:38 EDT
(In reply to Yin.JianHong from comment #5)
> I means that  it should give user the reason directly in the stderr. 
> -like in RHEL6 and RHEL5
nfs-utils has no way of controlling that so you should open
up the bug against systemd.
Comment 7 Yin.JianHong 2013-08-29 06:30:39 EDT
(In reply to Steve Dickson from comment #6)
> (In reply to Yin.JianHong from comment #5)
> > I means that  it should give user the reason directly in the stderr. 
> > -like in RHEL6 and RHEL5
> nfs-utils has no way of controlling that so you should open
> up the bug against systemd.

Hi steve, thanks your explanation.
But from the customer perspective, we do not know the background complete,
why must use the systemd?? now  it  cause many issues ...
Comment 8 Steve Dickson 2013-08-29 07:07:41 EDT
(In reply to Yin.JianHong from comment #7)
> (In reply to Steve Dickson from comment #6)
> > (In reply to Yin.JianHong from comment #5)
> > > I means that  it should give user the reason directly in the stderr. 
> > > -like in RHEL6 and RHEL5
> > nfs-utils has no way of controlling that so you should open
> > up the bug against systemd.
> 
> Hi steve, thanks your explanation.
> But from the customer perspective, we do not know the background complete,
> why must use the systemd?? now  it  cause many issues ...

Back in the Fedora 17 time frame there was a big push to speed
up boot/reboot speeds. So it was decided to have system services 
start asynchronous instead of synchronous like the old system 5
scripts were. So old /bin/init process was replaced by systemd.

Unfortunately the systemd people did not care or think it was
necessary to be backwards compatible with the old scripts.

So yes, systemd has caused a lot of problems but its also solved
a few...

Note You need to log in before you can comment on or make changes to this bug.