Bug 994999 - "We couldn't create a new partition or locate an existing one." when trying to install OS into IDE disk, a scsi-disk was attached with lun=0
"We couldn't create a new partition or locate an existing one." when trying t...
Status: CLOSED DUPLICATE of bug 1047733
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: 7.0
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 07:36 EDT by Chao Yang
Modified: 2014-06-09 08:01 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 06:00:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chao Yang 2013-08-08 07:36:56 EDT
Description of problem:
Started a guest with ide and virtio-scsi disks attached. When trying to install windows OS into ide disk, I hit "We couldn't create a new partition or locate an existing one. For more information, see the Setup log files" after clicking "Next".

1. Changing lun=0 in cli to lun=1 worked around this issue.
2. Installing virtio-scsi driver worked around this issue before clicking 'Next'

If this bug is not a bug, please clarify why, why changing to lun=1 or installing virtio-scsi driver(with lun=0 set) works?

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.382.el6.x86_64
2.6.32-407.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
CLI:
/usr/libexec/qemu-kvm -name test -M rhel6.5.0 -cpu host -enable-kvm -m 2048 -smp 2,sockets=4,cores=2,threads=1,maxcpus=8 -rtc base=localtime,clock=host,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0 -chardev socket,id=channel0,path=/tmp/socket,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=channel0,name=port0 -device virtio-scsi-pci,id=scsi -drive file=/home/data.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device scsi-disk,bus=scsi.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1,lun=0 -drive file=/home/testinstall.qcow2,if=none,id=ide,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,drive=ide,bus=ide.1,unit=1 -netdev tap,id=hostnet1 -device e1000,netdev=hostnet1,id=net1,mac=00:1a:4a:42:48:12,bus=pci.0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:42:48:ab,bus=pci.0,bootindex=3 -spice port=5900,disable-ticketing,seamless-migration=on -k en-us -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=33554432 -device intel-hda,id=sound0,bus=pci.0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -balloon virtio -monitor stdio -serial unix:/tmp/serial,server,nowait -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -cdrom en_windows_server_2012_x64_dvd_915478.iso -boot menu=on -fda /usr/share/virtio-win/virtio-win-1.6.5_amd64.vfd
Comment 2 Asias He 2013-08-27 05:22:51 EDT
Reproduced this on win7 and win2012.
Comment 3 Asias He 2013-08-27 22:43:00 EDT
I can not reproduce this installing rhel6.5 guest with the same setup. This might be a windows specific issue.
Comment 4 Asias He 2013-09-02 19:53:15 EDT
Yan, would you take a look at this issue. Thanks.
Comment 7 Ademar Reis 2014-01-02 15:08:06 EST
(In reply to Asias He from comment #4)
> Yan, would you take a look at this issue. Thanks.

Yan, you cleared the needinfo() flag, but added no comments. Do you have any idea of what's going on here?
Comment 8 Yan Vugenfirer 2014-01-05 08:08:39 EST
(In reply to Ademar de Souza Reis Jr. from comment #7)
> (In reply to Asias He from comment #4)
> > Yan, would you take a look at this issue. Thanks.
> 
> Yan, you cleared the needinfo() flag, but added no comments. Do you have any
> idea of what's going on here?

I think it happened by mistake. I wanted to move the bug or the need_info to Vadim who is responsible for virtio-scsi.
Comment 9 Vadim Rozenfeld 2014-01-12 07:24:20 EST
Can we please try the latest drivers from build 74?
I was able to install it on Win7SP1 with the following command line

-name test -M pc -cpu host -enable-kvm -m 2048 -smp 2,sockets=4,cores=2,threads=1,maxcpus=8 -rtc base=localtime,clock=host,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi -drive file=/home/vrozenfe/work/images/windows7.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device scsi-disk,bus=scsi.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1,lun=0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=24:2A:44:3F:2F:5A,id=net0 -vga std -monitor stdio -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -cdrom /home/vrozenfe/work/isos/en_windows_7_professional_with_sp1_x86_dvd_u_677056.iso -boot menu=on -fda /home/vrozenfe/work/isos/vioscsi.vfd -drive file=/home/vrozenfe/work/images/test.qcow2,if=none,id=ide,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,drive=ide,bus=ide.1,unit=1

without any flaws.

Thaks,
Vadim.
Comment 10 Chao Yang 2014-01-12 22:24:35 EST
(In reply to Vadim Rozenfeld from comment #9)
> Can we please try the latest drivers from build 74?
> I was able to install it on Win7SP1 with the following command line
> 
> -name test -M pc -cpu host -enable-kvm -m 2048 -smp
> 2,sockets=4,cores=2,threads=1,maxcpus=8 -rtc
> base=localtime,clock=host,driftfix=slew -device
> piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi
> -drive
> file=/home/vrozenfe/work/images/windows7.qcow2,if=none,id=drive-virtio-disk0,
> format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device
> scsi-disk,bus=scsi.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1,
> lun=0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device
> e1000,netdev=hostnet0,mac=24:2A:44:3F:2F:5A,id=net0 -vga std -monitor stdio
> -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -cdrom
> /home/vrozenfe/work/isos/en_windows_7_professional_with_sp1_x86_dvd_u_677056.
> iso -boot menu=on -fda /home/vrozenfe/work/isos/vioscsi.vfd -drive
> file=/home/vrozenfe/work/images/test.qcow2,if=none,id=ide,format=qcow2,
> cache=none,werror=stop,rerror=stop,aio=native -device
> ide-drive,drive=ide,bus=ide.1,unit=1
> 
> without any flaws.
> 
It is still reproducible with -74 to me. Without loading vioscsi driver first, it is not allowed to proceed to install OS onto ide disk.

> Thaks,
> Vadim.
Comment 11 Vadim Rozenfeld 2014-01-13 01:14:59 EST
(In reply to Chao Yang from comment #10)
> (In reply to Vadim Rozenfeld from comment #9)
> > Can we please try the latest drivers from build 74?
> > I was able to install it on Win7SP1 with the following command line
> > 
> > -name test -M pc -cpu host -enable-kvm -m 2048 -smp
> > 2,sockets=4,cores=2,threads=1,maxcpus=8 -rtc
> > base=localtime,clock=host,driftfix=slew -device
> > piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi
> > -drive
> > file=/home/vrozenfe/work/images/windows7.qcow2,if=none,id=drive-virtio-disk0,
> > format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device
> > scsi-disk,bus=scsi.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1,
> > lun=0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device
> > e1000,netdev=hostnet0,mac=24:2A:44:3F:2F:5A,id=net0 -vga std -monitor stdio
> > -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -cdrom
> > /home/vrozenfe/work/isos/en_windows_7_professional_with_sp1_x86_dvd_u_677056.
> > iso -boot menu=on -fda /home/vrozenfe/work/isos/vioscsi.vfd -drive
> > file=/home/vrozenfe/work/images/test.qcow2,if=none,id=ide,format=qcow2,
> > cache=none,werror=stop,rerror=stop,aio=native -device
> > ide-drive,drive=ide,bus=ide.1,unit=1
> > 
> > without any flaws.
> > 
> It is still reproducible with -74 to me. Without loading vioscsi driver
> first, it is not allowed to proceed to install OS onto ide disk.

Got you, 
I was thinking that you failed to install Windows on vioscsi drive.
Will check it again.

> 
> > Thaks,
> > Vadim.
Comment 12 Ronen Hod 2014-02-25 06:00:27 EST
With slight differences, identical to 1047733

*** This bug has been marked as a duplicate of bug 1047733 ***

Note You need to log in before you can comment on or make changes to this bug.